Two clicks required to refresh page instead of one (a.k.a. restore the stop-reload button)

RESOLVED WORKSFORME

Status

()

Firefox
Address Bar
RESOLVED WORKSFORME
8 years ago
8 years ago

People

(Reporter: klonos, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

8 years ago
In the latest 4.0b6pre versions of fx the stop/reload button was moved inside the location bar.

I know we are trying to minimize everything and all, but this is a bit of a UX pullback. If we ignore the keyboard shortcut available for a moment here (not everyone is familiar with them), one now has to click once in the location bar in order to display the reload button and a second time on the button to actually refresh the page. Previously, all you had to do is simply click once on the toolbar button and do it.

At least make this change optional like the 'tabs on top/bottom' feature.

Another way I can think of in order to solve this is to show the button on hover-over the location bar instead of requiring to click inside it. But, still this newly-introduced feature needs to be optional (if not entirely re-thought and reverted).

Comment 1

8 years ago
The refresh button is one click and always available on a loaded page. Are you referring to reloading a page that's already in the progress of loading, and thus has the stop button still? Or, are you referring to accessing the go button as apposed to refresh?

See this for all possible states: attachment 471833 [details]

(In reply to comment #0)
> At least make this change optional like the 'tabs on top/bottom' feature.

This is already optional. You can customize the toolbar and rip the stop and reload buttons out and move them wherever you wish.

Updated

8 years ago
Blocks: 544816

Updated

8 years ago
Blocks: 343396
No longer blocks: 544816
(Reporter)

Comment 2

8 years ago
Well, then it must be one of the location bar extensions I am using because the only places I am able to see the refresh button without having to first click on the location bar is in about:addons and about:config.

So it must be either 'CyberSearch' + 'Enter Selects' or 'Locationbar2'.

Anyone else using these and having the same issue?

As for the screenshot you've provided, I don't have the button on the right side of the location bar. Mine shows to the left, right between the favicon + site verification and the URL (please see attached Win7 64bit screenshot to see what I mean). I was used to right-clicking on the toolbar -> selecting 'Customize...' and then being able to drag the stop/reload button wherever I wanted. Now, I see no such button available in the 'Customize Toolbar' dialog. They are on the toolbar while the dialog is open, but disappear once I close the dialog (see second screenshot).
(Reporter)

Comment 3

8 years ago
Created attachment 472398 [details]
location bar with stop/reload button states
(Reporter)

Comment 4

8 years ago
Created attachment 472399 [details]
Stop & Reload buttons disappear when the Customize Tollbar dialog is closed
(Reporter)

Comment 5

8 years ago
...actually the two 'stop' & 'reload' toolbar buttons were on the right side of the toolbar before I took the second screenshot. So I had to move them to the left (in order to make the screenshot as small as possible).

After doing this (moving the buttons to the right side I mean) the behavior has changed. I see no icons/buttons to the right of the URL inside the location bar at all. Only the 'Stop' button is shown while a page is loading at the left of the location bar as separate button. After it has finished loading, it is momentarily replaced by the refresh button (for a second) and the an empty space is left in their place (as shown at the top of the second screenshot).
(Reporter)

Comment 6

8 years ago
...so I am able to stop a page from loading, but still I cannot refresh it (unless I hit F5 of course).

I just moved the toolbar buttons to the right of the location bar again and I verify that when placing them there I have the red/blue/green buttons inside the location bar (with the issue described in comments #0 & #2). When I move them to the left (between the back/forward & home buttons), I see no red/blue/green buttons inside the location bar at all.

In both positions the toolbar buttons behave as described in comment #5.

If all this is confusing, I might spend some time to provide a screencast.

Comment 7

8 years ago
(In reply to comment #2)
> So it must be either 'CyberSearch' + 'Enter Selects' or 'Locationbar2'.

I use CyberSearch 2.0.6 with the latest nightly, so unless there's a specific option in it that hurts something it's probably not that one. If you think it's an extension, which is a good guess, then:
http://support.mozilla.com/en-US/kb/Troubleshooting+extensions+and+themes

Seeing what it's supposed to look like from the start of a new profile will help too:
http://support.mozilla.com/en-US/kb/Managing+Profiles

I'm not sure what's going on in those screenshots. To get it on the right, customize the toolbar to put the refresh and stop buttons to the direct right of the address bar and they'll merge into the new go/stop/reload multi-state button. You can still go back and put them elsewhere, but they won't be the new combined 3-state button, they'll still be able to combine into the old 2-state stop/reload button though. It's like a puzzle...
(Reporter)

Comment 8

8 years ago
Thanx Dave, but I already knew how to place it on the right. The issue is that it was placed there, but the refresh icon would not show up after page load (only the stop button while page loading), leaving an empty space in its place.

Anyways... good news is that after yesterday's nightly update the issue went away. I don't know what fixed it, but it is fixed now ;)
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED

Comment 9

8 years ago
Status should be WORKSFORME then, not FIXED, unless you can cite the fix.
(yeah, nitpicking a bit, but still true) If anyone finds the bug that fixed this, feel free to dupe this there.
Resolution: FIXED → WORKSFORME

Updated

8 years ago
No longer blocks: 343396
You need to log in before you can comment on or make changes to this bug.