XIF: Copy/pasted JPN text body does not work

VERIFIED DUPLICATE of bug 8427

Status

MailNews Core
Internationalization
P3
normal
VERIFIED DUPLICATE of bug 8427
18 years ago
9 years ago

People

(Reporter: Katsuhiko Momoi, Assigned: Akkana Peck)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
** Checked with 5/3/99 Win32 M5 candidate build **

Now that we can see the Japanese text body sent from 5.0 (due to the
fix in Bug 5525), we can see what happens to a Japanese text which
is copy/pasted in as opposed to input via JPN IME.

Such text would not show as Japanese on the mail text composer
window -- actually looks like Shift_JIS text displayed with Latin 1
encoding.
When such text is sent out, it goes out in Shift_JIS and generally
get Base 64-encoded by servers such as Netscape 4.01.

In any case, we need to correct this so that 1) copy/pasting works
in Japanese into the mail text body and 2) no Shift_JIS mail goes
out. Perhaps these are due to some known bug, but I'm filing it
anyway to see if such a bug exists.

Updated

18 years ago
Assignee: nhotta → kostello
Summary: Copy/pasted JPN text body goes out in Shift_JIS → Copy/pasted JPN text body does not work

Comment 1

18 years ago
As momoi@netscape.com mentioned in his comment, the pasted text is just looks
like Shift_JIS but acutally not. So bug 2) is invalid and I changed the title.
Reassign to kostello@netscape.com

Updated

18 years ago
Status: NEW → ASSIGNED

Comment 2

18 years ago
Akkana is the new owner of the clipboard/xif/document encoding work so I changed
ownership to her. [I did add my new e-mail address to the CC list though :)]

Comment 3

18 years ago
Actually, Bugzilla wouldn't accept my change for the CC field, but leaf assures
me that when I get my new account all references to my old e-mail address will
be updated with my new address.
(Assignee)

Updated

18 years ago
Target Milestone: M8

Updated

18 years ago
Blocks: 7228
(Assignee)

Updated

18 years ago
Summary: Copy/pasted JPN text body does not work → XIF: Copy/pasted JPN text body does not work
(Assignee)

Comment 4

18 years ago
Somehow the status on all of these got set back to New; re-accepting them.
(Assignee)

Comment 5

18 years ago
Move XIF/I18n bugs to M9; they're dependant on stubs which I18n is trying to get
in for M8.
(Assignee)

Updated

18 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE
(Assignee)

Comment 6

18 years ago
This looks like a dup of 8427.

*** This bug has been marked as a duplicate of 8427 ***
(Reporter)

Updated

18 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Comment 7

18 years ago
OK. I'll keep track of this bug via Bug 8427.
Marking verified as duplicate.
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.