Closed Bug 593927 Opened 10 years ago Closed 6 years ago

Google maps route markers are flashy

Categories

(Web Compatibility :: Desktop, defect)

x86_64
Windows 7
defect
Not set

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: tnikkel, Unassigned)

References

()

Details

(Keywords: regression)

Goto http://gmap-pedometer.com/. Switch to Hybrid and zoom in as far as you can and still have the roads overlaid on the images. Click Start recording. Double click on a road somewhere. Double click somewhere else on a road. Keep drawing a path so that the map has to scroll. Watch the red start/end markers. They flash in and out instead of staying solid.

Regression range: http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=beab39d49de9&tochange=b26489e73818
Guessing bug 572520
blocking2.0: --- → ?
Assignee: nobody → joe
blocking2.0: ? → final+
Keywords: regression
Whiteboard: [3 days]
You don't even need to wait for autoscroll - just scrolling around manually with the mouse causes the markers to flash.

To be clear, the reason this is blocking is because it's a regression from a bug that should have had no functional change, and it seems pretty unlikely that it would be restricted to this site.
Whiteboard: [3 days] → [3 days][soft blocker]
Whiteboard: [3 days][soft blocker] → [3 days][softblocker]
When you scroll, it seems (it is *very* hard to tell for sure, because of the crazily-obfuscated source code) that gmaps loads a new image with the same URL. In the past, we'd display that image immediately, because it was already loaded, but since bug 572520, we delay the load (= "you can display this image") events until a run through the event loop.

In other words, this is a bug in the webpage. -> Tech Evang.
Assignee: joe → english-us
blocking2.0: final+ → ---
Component: ImageLib → English US
Product: Core → Tech Evangelism
QA Contact: imagelib → english-us
Whiteboard: [3 days][softblocker]
Version: Trunk → unspecified
No issue.
Assignee: english-us → nobody
Status: NEW → RESOLVED
Closed: 6 years ago
Component: English US → Desktop
Resolution: --- → WORKSFORME
Product: Tech Evangelism → Web Compatibility
You need to log in before you can comment on or make changes to this bug.