Closed Bug 5941 Opened 22 years ago Closed 20 years ago

CSS1 fonts not mapped correctly for double-byte content

Categories

(Core :: Internationalization, defect, P2, major)

PowerPC
All
defect

Tracking

()

VERIFIED WORKSFORME

People

(Reporter: jpm, Assigned: erik)

References

()

Details

(This bug imported from BugSplat, Netscape's internal bugsystem.  It
was known there as bug #122897
http://scopus.netscape.com/bugsplat/show_bug.cgi?id=122897
Imported into Bugzilla on 05/04/99 22:37)

When using style sheets (CSS1) to define fonts for HTML elements for a Shift_JIS
document, it appears that fonts not able to display SJIS are used, even though a
valid SJIS font (Osaka) is defined in the style sheet. Also, the default styles
(serif, sans-serif, ...) seem to use wrong fonts for SJIS display.

(The use of "serif" etc. is described in
http://developer.netscape.com/docs/manuals/communicator/dynhtml/jss34.htm#103040
2)

Using the US client on an US system with a language kit installed should still
have valid font mappings for sans-serif etc. for the encodings we support.
Added URL for testing:
http://rocknroll/users/jpm/publish/l10n/tests/122987.html.

Notice that the document displays correctly on a Windows 4.x client.
reassigning to engineer
Half of this is not a bug but half of them is.
The bug part -
> Using the US client on an US system with a language kit installed should still
> have valid font mappings for sans-serif etc. for the encodings we support.
Agree, dp, please assign engineer to solve this.

Not a bug part-
The reason this page does not render correctly (except H4, which use san-serif
as mention above) is it list Osaka font AFTER Helvetica. Since all Mac have
Helvetica font installed, it will use Helvetica to render the Japanese text, the
solution is (1) delete Helevetica from the list (why you put there any way ?) or
(2) put Osaka before Helvetica.
Frank,

Notice how the Windows client renders the page correctly using Japanese fonts,
even though the font list specifies "Ariel", but no Japanese fonts.

If using "Ariel" to display Japanese content works on Windows, so should using
"Helvetica" on Mac OS. There probably is some special-case code for dealing with
this on WinFE that the MacFE (possibly XFE) would need.
can someone figure out if this is regression since 4.05?
I tested 4.05 MAC PPC and 7-17-98 4.06 PPC build.  This happens in both build.
gotta move to to 5.0.  might consider in 4.5 if a fix appears..
My favorite question, "Is this bug still relevant in the new 5.0 world?"

------- Additional Comments From paulmac  May-04-1999 17:59 -------

Okay, time to close out old bugsplat bugs - Please move to bugzilla if this
one is still relevant or mark won't fix, please.
Assignee: harishd → erik
Status: ASSIGNED → NEW
OS: All
Priority: P1 → P2
Target Milestone: M6
Status: NEW → ASSIGNED
Target Milestone: M6 → M15
I will decide later which milestone to fix this in.
Target Milestone: M15 → M10
Blocks: 7228
Target Milestone: M10 → M12
Target Milestone: M12 → M14
Teruko, Is this bug still valid?
Status: ASSIGNED → RESOLVED
Closed: 20 years ago
Resolution: --- → WORKSFORME
Status: RESOLVED → VERIFIED
This does not happen in 110909 MAC build.
You need to log in before you can comment on or make changes to this bug.