Closed Bug 594236 Opened 11 years ago Closed 10 years ago

Add interactive jobs chooser to push-to-try

Categories

(Release Engineering :: General, defect, P5)

defect

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: justin.lebar+bug, Unassigned)

References

Details

(Whiteboard: [tryserver])

I continue to mess up the try: syntax.  Even if the syntax were totally intuitive, there are still plenty of ways for me to screw up -- most recently, I forgot the "try:"!

Why not have a pre-commit hook *ask* what builds you'd like to run?  This might solve lots of usability issues all at once.
This might not be that hard to do if the commit hook just changed the commit message to the appropriate syntax.
Priority: -- → P5
Whiteboard: [tryserver]
it is, however, a reimplementation of the code.  That makes it easier for this script to drift from what is actually happening.
(In reply to comment #3)
> it is, however, a reimplementation of the code.  That makes it easier for this
> script to drift from what is actually happening.

Agreed.  It's also something that people have to install and keep up to date.

otoh, we already have qimportbz and qexportbz.
http://people.mozilla.org/~lsblakk/trychooser/trychooser.html  might help while we continue to work on an improved dashboard/checkin hook.
Duplicate of this bug: 591688
Not knowing about khuey's implementation, I wrote my own: https://hg.mozilla.org/users/pbiggar_mozilla.com/trychooser/. Does the same, but uses an interactive prompt rather than a file (I think I like the file better).
(In reply to comment #7)
> Not knowing about khuey's implementation, I wrote my own:
> https://hg.mozilla.org/users/pbiggar_mozilla.com/trychooser/. Does the same,
> but uses an interactive prompt rather than a file (I think I like the file
> better).

Thanks to pbiggar's extension I believe we can call this fixed.
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.