Closed Bug 594333 Opened 14 years ago Closed 14 years ago

smeared pixels when elements with background-image & background-position are moved around

Categories

(Core :: Layout, defect)

defect
Not set
major

Tracking

()

RESOLVED FIXED
mozilla2.0b8
Tracking Status
blocking2.0 --- final+

People

(Reporter: bugzilla33, Assigned: roc)

References

Details

(Keywords: regression, testcase)

Attachments

(4 files, 2 obsolete files)

User-Agent:       Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1; Trident/4.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; InfoPath.2; .NET4.0C; .NET4.0E; FDM; Tablet PC 2.0)
Build Identifier: Mozilla/5.0 (Windows NT 6.1; rv:2.0b5) Gecko/20100101 Firefox/4.0b5

Run attachment and TEST.

Reproducible: Always

Steps to Reproduce:

1. Use Windows 7 32-bit
2. Run this TEST with FF 3.x - exelent animation
3. Run this TEST with FF 4.0b5 - distorted picture during animation.

Actual Results:  

distorted picture during animation


Expected Results:  

exelent animation
Attached file testcase.html (obsolete) —
Attached image testcase.jpg
Version: unspecified → Other Branch
Attachment #473016 - Attachment is obsolete: true
Attached file testcase.html
Component: JavaScript Engine → Layout
Component: Layout → Layout: View Rendering
Version: Other Branch → Trunk
Component: Layout: View Rendering → Style System (CSS)
Assignee: general → nobody
QA Contact: general → style-system
Confirmed on Linux
Mozilla/5.0 (X11; Linux x86_64; rv:2.0b6pre) Gecko/20100908 Firefox/4.0b6pre

The leftmost column of pixels in each picture gets "smeared" leftwards. If I 
trigger an invalidation during the animation (by clicking the title bar or clicking an image), it repaints correctly - but then it starts "smearing" again from that point on.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows 7 → All
Hardware: x86 → All
Not broken:
Mozilla/5.0 (X11; Linux i686 (x86_64); en-US; rv:2.0b2pre) Gecko/20100715 Minefield/4.0b2pre
20100715030655 5fda39cd703c

Broken:
Mozilla/5.0 (X11; Linux i686 (x86_64); en-US; rv:2.0b2pre) Gecko/20100716 Minefield/4.0b2pre
20100716025911 96de199027d7

Regression range:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=5fda39cd703c&tochange=96de199027d7

Looks likely to be a regression from retained layers.
Blocks: 564991
blocking2.0: --- → ?
Component: Style System (CSS) → Layout
QA Contact: style-system → layout
Summary: distorted picture during animation → smeared pixels when elements with background-image & background-position are moved around
Keywords: testcase
Assignee: nobody → roc
Attached patch fix (obsolete) — Splinter Review
Moving a float that might contain layers needs to invalidate the layer contents.
Attachment #475381 - Flags: review?(dbaron)
Whiteboard: [needs review]
Comment on attachment 475381 [details] [diff] [review]
fix

Shouldn't you check whether the float moved, and only invalidate when it did?  r=dbaron with that
Attachment #475381 - Flags: review?(dbaron) → review+
-> [needs landing] ?
(not quite -- [needs review tweak before landing], per comment 7)
Attached patch v2Splinter Review
OK, now this is ready to land.
Attachment #475381 - Attachment is obsolete: true
Keywords: checkin-needed
Whiteboard: [needs review] → [needs landing]
URL: none
Landed: http://hg.mozilla.org/mozilla-central/rev/7510a8ab857d
Status: NEW → RESOLVED
Closed: 14 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Whiteboard: [needs landing]
Target Milestone: --- → mozilla2.0b8
Backed out:
  http://hg.mozilla.org/mozilla-central/rev/fcd702dc1ec7
since the included reftest was failing on Win Debug (the only Win reftest cycle to have completed so far):
  http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1292008235.1292011445.2790.gz
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Attached file reftest failure log
Here's the Win Debug reftest failure log, for convenience.
Attachment #496904 - Attachment is patch: false
http://hg.mozilla.org/mozilla-central/rev/10f6af33d3fb
Status: REOPENED → RESOLVED
Closed: 14 years ago14 years ago
Resolution: --- → FIXED
Depends on: 1322257
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: