[BLOCK]ender- Mouse Events don't work with *GFX* OPTGROUP or OPTION elements

VERIFIED FIXED in M10

Status

()

Core
HTML: Form Submission
P3
blocker
VERIFIED FIXED
19 years ago
19 years ago

People

(Reporter: David Hyatt, Assigned: Kevin McCluskey (gone))

Tracking

Trunk
x86
Other
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [PDT+]Need this in M10)

(Reporter)

Description

19 years ago
The onchange handler for SELECT elements fires at the wrong time.  It is being
fired when the mouse is clicked in the SELECT element, which seems to just be
wrong.

It should be fired when the element loses focus AND has changed since last
gaining the focus.  This is specified in the DOM Level 2 working draft and also
in the JavaScript 1.2 Reference on developer.netscape.com.
(Reporter)

Updated

19 years ago
Summary: onchange handler on SELECT elements fires at the wrong time. → [BLOCK] Mouse Events don't work with SELECT elements
(Reporter)

Updated

19 years ago
Summary: [BLOCK] Mouse Events don't work with SELECT elements → [BLOCK] Mouse Events don't work with SELECT or OPTION elements
(Reporter)

Comment 1

19 years ago
You can't attach simple click handlers to SELECT elements.  The click handler on
the SELECT element never fires.  Moreover, a click on a child OPTION element
never bubbles up, either to an OPTGROUP or to the SELECT.  I am assuming that
all mouse events are broken.

Take a look at the HTML4 spec on w3.org to see the set of events that
SELECT, OPTGROUP, and OPTION should be prepared to respond to.

This is a high priority bug, since between the inability to register click
handlers, and the disfunctional onchange handler, we have no way of using combo
boxes as reliable widgets.
(Reporter)

Comment 2

19 years ago
You can't attach simple click handlers to SELECT elements.  The click handler on
the SELECT element never fires.  Moreover, a click on a child OPTION element
never bubbles up, either to an OPTGROUP or to the SELECT.  I am assuming that
all mouse events are broken.

Take a look at the HTML4 spec on w3.org to see the set of events that
SELECT, OPTGROUP, and OPTION should be prepared to respond to.

This is a high priority bug, since between the inability to register click
handlers, and the disfunctional onchange handler, we have no way of using combo
boxes as reliable widgets.

Updated

19 years ago
Assignee: karnaze → pollmann
Target Milestone: M7

Updated

19 years ago
Target Milestone: M7 → M6

Comment 3

19 years ago
Reassigning to Pollmann. Please solicit help from Pixley if needed.

Updated

19 years ago
Severity: normal → blocker

Comment 4

19 years ago
Changed severity to "blocker". It certainly is for the Editor, and probably is
for other groups as well

Comment 5

19 years ago
*** Bug 5936 has been marked as a duplicate of this bug. ***

Updated

19 years ago
Summary: [BLOCK] Mouse Events don't work with SELECT or OPTION elements → [BLOCK]ender- Mouse Events don't work with SELECT or OPTION elements

Updated

19 years ago
Status: NEW → ASSIGNED

Comment 6

19 years ago
I'll be trying to get most of this in M6.

Comment 7

19 years ago
The OnChange behaviour is reported as bug 3322.

OnClick works fine for me on SELECT listboxes.
http://blueviper/forms/onclick.html

OnClick for SELECT comboboxes works in the text entry field but not the
drop-down list.  This should be also fixed for M6.
http://blueviper/forms/onclick2.html

Mouse events on options and optgroups are not handled at all right now and I
haven't done work to assess them yet - so they may not make it into M6.

Updated

19 years ago
Summary: [BLOCK]ender- Mouse Events don't work with SELECT or OPTION elements → [BLOCK]ender- Mouse Events don't work with OPTGROUP or OPTION elements
Target Milestone: M6 → M7

Comment 8

19 years ago
I've made note of the fact that mouse events on the drop down list of a combo
box don't get bubbled up (or in fact ever enter the event system) in bug 3322.

The only remaining issue for this bug not covered by 3322 is that events don't
get routed to options or optgroups, but instead start out at the select.

Updated

19 years ago
Target Milestone: M7 → M12

Comment 9

19 years ago
This remaining problem should go away when GFX widgets become the default.

Postponing this one until "much later"

Updated

19 years ago
Blocks: 11346

Updated

19 years ago
Whiteboard: Need this in M10

Comment 10

19 years ago
Need this early in M10!

Updated

19 years ago
Assignee: pollmann → kmcclusk
Status: ASSIGNED → NEW
Summary: [BLOCK]ender- Mouse Events don't work with OPTGROUP or OPTION elements → [BLOCK]ender- Mouse Events don't work with *GFX* OPTGROUP or OPTION elements

Comment 11

19 years ago
I'm splitting this bug, one for GFX widgets (which should be fixed ASAP) and one
for native widgets (which is low priority and may not get fixed right away if
ever).  Since this is the bug with the most history, I'll leave this as the GFX
bug.  Reassigning Kevin McCluskey.  I'll hold on to the Native bug 11797 just as
a bookmark.
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
Target Milestone: M12 → M10
(Assignee)

Comment 12

19 years ago
Moving to M10
(Assignee)

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
(Assignee)

Comment 13

19 years ago
gfx selects enabled as default as of Aug 19, 1999 4:00PM.

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 14

19 years ago
http://blueviper/forms/onclick.html seems to have a javascript error ('dump not
defined') and it does nothing in 4.7 or 5.0.
http://blueviper/forms/onclick2.html tells me that onclick is working.
I suppose that means that this is fixed for gfx widgets. Marking verified.

Updated

19 years ago
Whiteboard: Need this in M10 → [PDT+]Need this in M10

Comment 15

19 years ago
Putting on [PDT]+ radar.

Updated

18 years ago
No longer blocks: 11346
You need to log in before you can comment on or make changes to this bug.