The default bug view has changed. See this FAQ.

Autoupdate to 2.0.7 seems to be broken (crash on startup)

RESOLVED FIXED

Status

SeaMonkey
Release Engineering
--
blocker
RESOLVED FIXED
7 years ago
7 years ago

People

(Reporter: Bruno 'Aqualon' Escherl, Assigned: Robert Kaiser)

Tracking

({fixed-seamonkey2.0.8, fixed-seamonkey2.0.9})

SeaMonkey 2.0 Branch
fixed-seamonkey2.0.8, fixed-seamonkey2.0.9
Bug Flags:
blocking-seamonkey2.0.8 +

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

7 years ago
http://crash-stats.mozilla.com/products/SeaMonkey/versions/2.0.7

Lot's of crash reports on startup after autoupdate :-/
(Assignee)

Comment 1

7 years ago
I have temporarily pulled updates for 2.0.6 -> 2.0.7 - and I might have an idea what could be done to fix it.
(Assignee)

Comment 2

7 years ago
I don't have confirmation right now if that helps, but as bug 530447 suggests frankenbuilds of some sort and plays with compreg.dat maybe needing removal, I re-checked our removal of it on update and it turns out that the fool who did the bug 562047 patch (i.e. me) was confused as to the location of those files and didn't realize they live in components/ and not directly in the app dir.
(Assignee)

Comment 3

7 years ago
Created attachment 473298 [details] [diff] [review]
comm-1.9.1 patch

I sincerely hope we get feedback that killing those files helps. If so, we'll do a firedill for this as fast as we can and go 2.0.8 even though the actual code won't change.
Assignee: nobody → kairo
Status: NEW → ASSIGNED
Attachment #473298 - Flags: review?(bugspam.Callek)
Attachment #473298 - Flags: approval-seamonkey2.0.8?

Updated

7 years ago
Attachment #473298 - Flags: review?(bugspam.Callek)
Attachment #473298 - Flags: review+
Attachment #473298 - Flags: approval-seamonkey2.0.8?
Attachment #473298 - Flags: approval-seamonkey2.0.8+
(Assignee)

Comment 4

7 years ago
Created attachment 473304 [details] [diff] [review]
comm-central patch

Here's the same patch for c-c (context is slightly different)
Attachment #473304 - Flags: review?(bugspam.Callek)

Updated

7 years ago
Attachment #473304 - Flags: review?(bugspam.Callek) → review+
(Assignee)

Comment 5

7 years ago
Pushes of the compreg/xpti patch:
http://hg.mozilla.org/comm-central/rev/e4fba053742f
http://hg.mozilla.org/releases/comm-1.9.1/rev/4702557ae9b2
http://hg.mozilla.org/releases/comm-1.9.1/rev/a1b25b5742ca

I'll wait for reports from people on if deleting the compreg.dat file helps them before I start a firedrill.
(Reporter)

Comment 6

7 years ago
So far one report from David E. Ross on http://groups.google.com/group/mozilla.support.seamonkey/msg/0b1b55e6e0d6bd42 that deleting compreg.dat helped.
(Reporter)

Comment 7

7 years ago
See also bug 594699.
See Also: → bug 594699

Comment 8

7 years ago
(In reply to comment #3)
> I sincerely hope we get feedback that killing those files helps. If so, we'll
> do a firedill for this as fast as we can and go 2.0.8 even though the actual
> code won't change.
I guess 2.0.6 -> 2.0.8 won't be an incremental update...
(Assignee)

Comment 9

7 years ago
(In reply to comment #8)
> I guess 2.0.6 -> 2.0.8 won't be an incremental update...

Unfortunately no.
(Reporter)

Updated

7 years ago
Duplicate of this bug: 594274
(Assignee)

Updated

7 years ago
Summary: Autoupdate to 2.0.7 seems to be broken → Autoupdate to 2.0.7 seems to be broken (crash on startup)
(In reply to comment #9)
> (In reply to comment #8)
> > I guess 2.0.6 -> 2.0.8 won't be an incremental update...
> 
> Unfortunately no.

And a 2.0.7 Build2 isn't a clean solution, but those who hasn't got the automatic update by now will get a working incremental update and those who have updated without problems aren't affect either... Just a thought (and staying in sync with Thunderbird 3.0 version numbers).
(Assignee)

Comment 12

7 years ago
(In reply to comment #11)
> And a 2.0.7 Build2 isn't a clean solution

You name it. Version numbers are cheap, matching TB was nice but a coincidence in the end, and I'd rather tell users to "install 2.0.8" than to "install the newer variant of 2.0.7" - apart from that's it's not trivial to exchange files on the mirror system and still ensure it matches what we think it does.

The message to users must be clear in the way that 2.0.8 solves the problem - even if that means that anyone shipping things more cleanly (e.g. Linux distros, where this file won't be written into the app dir in the first place) will have to either stay at 2.0.7 or ship a basically null-update to 2.0.8 just for the number - code-wise and security-wise, it will not matter.
(Assignee)

Updated

7 years ago
No longer blocks: 590497
Flags: blocking-seamonkey2.0.8+
(Assignee)

Updated

7 years ago
Attachment #473298 - Flags: approval-seamonkey2.0.8+
(Assignee)

Comment 13

7 years ago
bug 594837 is tracking the oilspill release, bug 594699 the other thing behind this crash, so let's mark this one fixed.
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Keywords: fixed-seamonkey2.0.8
Resolution: --- → FIXED
(Assignee)

Updated

7 years ago
Keywords: fixed-seamonkey2.0.9
You need to log in before you can comment on or make changes to this bug.