Closed Bug 594697 Opened 14 years ago Closed 14 years ago

Adding MOZ_PLATFORM_MEEGO to config for MeeGo platform

Categories

(Firefox Build System :: General, defect)

x86
MeeGo
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: roger.wang, Unassigned)

References

Details

Attachments

(2 files, 2 obsolete files)

Attached patch enabling platform meego (obsolete) — Splinter Review
In the attached patch, MOZ_PLATFORM_MEEGO is defined so the platform can be built with '--enable-meego'. And various code guarding with MOZ_PLATFORM_MAEMO are also guarding with MOZ_PLATFORM_MEEGO.
Attachment #473440 - Flags: review?
Attachment #473440 - Flags: review? → review?(romaxa)
Why is the code added in Bug 583039 not sufficient?
MOZ_PLATFORM_MEEGO and MOZ_ENABLE_MEEGOTOUCH are for different purpose: MOZ_ENABLE_MEEGOTOUCH means using meego touch framework widget library, while MOZ_PLATFORM_MEEGO is for meego platform integration.
We've already got: http://mxr.mozilla.org/mozilla-central/source/configure.in#6879 --with-maemo-version=6, which lets you target meego. If you'd like to change that (or add an additional option) for --with-meego-version, I think that'd fit better.
maemo 6 and meego are different systems. maemo 6 starts before the maemo/moblin merge, and they have different base/library packages, build system, etc. so we need different options for different target systems at this transition period.
Attached patch patch v2 (obsolete) — Splinter Review
updated patch
Attachment #473440 - Attachment is obsolete: true
Attachment #474637 - Flags: review?
Attachment #473440 - Flags: review?(romaxa)
There should be support for different meego versions so --with-meego-version= instead of --enable-meego seems to be a better approach. Maybe it would than make sense to also define MOZ_PLATFORM_MEEGO=0 or MOZ_PLATFORM_MEEGO=1 in --with-maemo-version=6 case.
Comment on attachment 474637 [details] [diff] [review] patch v2 >-#if (MOZ_PLATFORM_MAEMO >= 6) >+#if (MOZ_PLATFORM_MAEMO >= 6) || defined (MOZ_PLATFORM_MEEGO) I think such creature as (MOZ_PLATFORM_MAEMO >= 6) should not exists anymore.... We have maemo5.... but that is the end of maemo name.... and after that we have only meego. Something need to be redone about it. > } > >-#if (MOZ_PLATFORM_MAEMO == 5) >+#if (MOZ_PLATFORM_MAEMO == 5) || defined (MOZ_PLATFORM_MEEGO) > case NPNVSupportsWindowlessLocal: { I'm not sure that we are going to support this in any future... dougt any ideas how to proceed with this change?
Attachment #474637 - Flags: feedback?(doug.turner)
oleg, feel free to clean up the #define such that: MOZ_PLATFORM_MAEMO 4 code is removed MOZ_PLATFORM_MAEMO 5 is MOZ_PLATFORM_MAEMO
Attachment #474637 - Flags: feedback?(doug.turner) → feedback-
Comment on attachment 474637 [details] [diff] [review] patch v2 So according to the comments, I'll make another patch, which will make the following change: MOZ_PLATFORM_MAEMO=5 --> MOZ_PLATFORM_MAEMO MOZ_PLATFORM_MAEMO=6 --> MOZ_PLATFORM_MEEGO=0 and MOZ_PLATFORM_MEEGO=1 means the upcoming Meego handset 1.1 release. Is that good? I'm hoping I'm not creating troubles on the maemo 6 development. Thanks.
Attachment #474637 - Attachment is obsolete: true
Attachment #474637 - Flags: review?
MOZ_PLATFORM_MAEMO=6 --> MOZ_PLATFORM_MEEGO=0 I'd rather not defined anything to zero. Are there any MOZ_PLATFORM_MAEMO=6 places that wouldn't work in 1.0? If so, is there a C #define for the version? Maybe you could do something like: #ifdef MOZ_PLATFORM_MEEGO #ifdef some_meego_specific_version == 1.1 ....
(In reply to comment #10) > MOZ_PLATFORM_MAEMO=6 --> MOZ_PLATFORM_MEEGO=0 > > I'd rather not defined anything to zero. > > > Are there any MOZ_PLATFORM_MAEMO=6 places that wouldn't work in 1.0? No such places so far. > If so, is > there a C #define for the version? > > Maybe you could do something like: > > #ifdef MOZ_PLATFORM_MEEGO > #ifdef some_meego_specific_version == 1.1 > .... so I'll upload a new patch doing: MOZ_PLATFORM_MAEMO=5 --> MOZ_PLATFORM_MAEMO MOZ_PLATFORM_MAEMO=6 --> MOZ_PLATFORM_MEEGO=1 and keep '--with-maemo-version=6' the same as '--with-meego-version=1' for now in mozconfig
Attached patch platform patchSplinter Review
Attachment #476592 - Flags: review?(ted.mielczarek)
Attached patch fennec patchSplinter Review
Attachment #476593 - Flags: review?(ted.mielczarek)
Attachment #476592 - Flags: review?(romaxa)
Attachment #476593 - Flags: review?(romaxa)
Comment on attachment 476593 [details] [diff] [review] fennec patch ># HG changeset patch ># Parent 5024622c731c3da725bab60b4c9f65ce50c2e4a6 > >diff --git a/app/mobile.js b/app/mobile.js >--- a/app/mobile.js >+++ b/app/mobile.js >@@ -36,6 +36,14 @@ > > #filter substitution > >+#ifdef MOZ_PLATFORM_MAEMO >+#define MAEMO_OR_MEEGO >+#endif >+ >+#ifdef MOZ_PLATFORM_MEEGO >+#define MAEMO_OR_MEEGO >+#endif >+ >@@ -161,6 +161,9 @@ > #ifdef MOZ_PLATFORM_MAEMO > Services.io.offline = false; > #endif >+#ifdef MOZ_PLATFORM_MEEGO >+ Services.io.offline = false; >+#endif don't really like this double code... would it be possible to define MAEMO_OR_MEEGO somewhere in common .js file? or somewhere else?
Attachment #476593 - Flags: review?(romaxa)
Attachment #476593 - Flags: review?(mark.finkle)
Attachment #476593 - Flags: feedback?(doug.turner)
I really don't like this name change. We use XP_UNIX in the code, and don't change it based on branding or marketing changes. In my mind, (MAEMO > 5) + QT = MEEGO Do we do this next year too, when Nokia changes the name of the OS again?
Comment on attachment 476593 [details] [diff] [review] fennec patch #if defined MOZ_PLATFORM_MEEGO || defined MOZ_PLATFORM_MAEMO instead of +#ifdef MOZ_PLATFORM_MAEMO +#define MAEMO_OR_MEEGO +#endif + +#ifdef MOZ_PLATFORM_MEEGO +#define MAEMO_OR_MEEGO +#endif
Attachment #476593 - Flags: feedback?(doug.turner) → feedback-
what is the reason of addin new platform name? can we just use platform_maemo=7 right now for meego, maemo6 for harmattan? I guess when nokia will stabilize names and release platforms with the same name, then we can make one more maemo/meego names re-consolidation and change defines. right now I dont see why this rename urgently needed. lets do this rename 1-2 years later.
up to you really.
suggesting this as wontfix or resolved-later
Status: NEW → RESOLVED
Closed: 14 years ago
Resolution: --- → WONTFIX
Attachment #476592 - Flags: review?(ted.mielczarek)
Attachment #476592 - Flags: review?(romaxa)
Attachment #476593 - Flags: review?(ted.mielczarek)
Attachment #476593 - Flags: review?(mark.finkle)
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: