right mouse button popup menu does not track menu items if the RMB is held down

VERIFIED DUPLICATE of bug 16766

Status

()

Core
Event Handling
P3
normal
VERIFIED DUPLICATE of bug 16766
17 years ago
17 years ago

People

(Reporter: Joel Becker, Assigned: joki (gone))

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.75 [en] (X11; U; Linux 2.2.18pre10-RAID-TSC i686)
BuildID:    2000110321

if you click the right mouse button (RMB) for a popup context menu, you can do
neat things.  If you click the RMB, then release, as you drag the mouse down the
menu the different items highlight.  When you click on an item, it is then
activated.  However, if you press the RMB *without* releasing, the menu still
pops up, but no menu item is ever highlighted.  Instead, you *must* release the
button, then click again.  This is contrary to normal Motif/GTK+/Win32/Mac
behavior, where a held button allows you to drag the menu item you wish to
select.  The proper behavior is evidenced in all other mozilla menus.

Reproducible: Always
Steps to Reproduce:
1.  Start Mozilla
2.  Press and hold the RMB in the layout pane.

Actual Results:  The popup menu failed to highlight any menu items, nor did it
take action on the one the mouse pointer was covering when I released the
button.  I had to release and click again to make any item take action.

Expected Results:  It should have highlighted the menu items as I dragged the
mouse over them, and should have activated the menu item I was over when I
released the button.

Comment 1

17 years ago
known issue -- bug 16766. thanks. 

(Side note: win32 behaviour is not to do this (instead the context menu comes
up on mouseup, not mousedown). Nav4 did do this on win32, but Mozilla will 
definitely not (old debate :-]

*** This bug has been marked as a duplicate of 16766 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 2

17 years ago
VERIFIED.
Status: RESOLVED → VERIFIED
(Reporter)

Comment 3

17 years ago
I'd agree that the Mozilla behavior on Win32 should mimic normal Win32, but I'm
on Unix (Linux, specifically) and I'd prefer the easy behavior.  I've looked at
the referenced bug.  Does that mean that it will not be fixed any time in the
near future?  I hope not, as it is seriously annoying.  Every time I RMB-click,
I get mad.

Thanks for the quick response.

Comment 4

17 years ago
Hmm, that is quite a messy bug (with all kinds of digressions and unrelated 
debates). The 'Future' milestone for that bug meant 'not this release' at the
time it was set. It should be retargeted soon.
You need to log in before you can comment on or make changes to this bug.