select list not greyed out when disabled, size and multiple attributes all set

RESOLVED FIXED in mozilla2.0b7

Status

()

Core
Layout: Form Controls
P1
normal
RESOLVED FIXED
7 years ago
7 years ago

People

(Reporter: beldaz.jalfrezi, Assigned: bz)

Tracking

({testcase})

Trunk
mozilla2.0b7
x86
Windows XP
testcase
Points:
---
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.2.2) Gecko/20100316 Firefox/3.6.2 ( .NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.2.2) Gecko/20100316 Firefox/3.6.2 ( .NET CLR 3.5.30729)

While creating an HTML form I found difficulty disabling portions using the "disabled" attribute. Further investigation showed that this attribute was not respected in select lists in conjunction with the "multiple" and "size" attributes.

Reproducible: Always

Steps to Reproduce:
1. Create a form containing a select list
2. Add the attribute disabled="disabled"
3. Add the attribute multiple="multiple"
4. Add the attribute size="4"
5. Try different combinations of the above attributes

Actual Results:  
The select box is disabled when the disabled attibute is set along with a combination of the other attributes, but when all attributes are set the box is no longer disabled.

Expected Results:  
Select box should be disabled in all cases where the diabled attibute is set. (Works correctly in IE8)
(Reporter)

Comment 1

7 years ago
Created attachment 473490 [details]
Simple HTML test case

This test case contains a form with three select lists holding the same options. All three lists have the "disabled" attribute set, and so should be disabled in the browser. In the reported bug, the first list (with "multiple" and "size" attributes also set) is not disabled.
Component: General → Layout: Form Controls
Keywords: testcase
Product: Firefox → Core
QA Contact: general → layout.form-controls
Version: unspecified → Trunk
Er... it's disabled just fine.  It just doesn't get the grayed-out coloring, right?
Created attachment 473659 [details] [diff] [review]
Fix
Assignee: nobody → bzbarsky
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Attachment #473659 - Flags: review?(dbaron)
Priority: -- → P1
(Reporter)

Comment 4

7 years ago
(In reply to comment #2)
> Er... it's disabled just fine.  It just doesn't get the grayed-out coloring,
> right?

You're quite right: it's disabled but not grayed out accordingly. Sorry for not diagnosing the bug correctly.
(Reporter)

Comment 5

7 years ago
Updated summary to avoid misleading reader
Summary: select disabled attribute not working when size and multiple attributes → select list not greyed out when disabled, size and multiple attributes all set
Thanks for double-checking that!
Comment on attachment 473659 [details] [diff] [review]
Fix

r=dbaron
Attachment #473659 - Flags: review?(dbaron)
Attachment #473659 - Flags: review+
Attachment #473659 - Flags: approval2.0+
Whiteboard: [need landing]
Pushed http://hg.mozilla.org/mozilla-central/rev/4817c29dc507
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Whiteboard: [need landing]
Target Milestone: --- → mozilla2.0b7
Duplicate of this bug: 588003
You need to log in before you can comment on or make changes to this bug.