Repaint problem of desktop(other application) when exit Fullscreen in Win XP/Win7 Classic

RESOLVED WORKSFORME

Status

()

Core
Widget: Win32
RESOLVED WORKSFORME
7 years ago
3 years ago

People

(Reporter: Alice0775 White, Unassigned)

Tracking

({regression})

Trunk
mozilla2.0
x86
Windows 7
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

7 years ago
Created attachment 473543 [details]
screenshot (exit Fullscreen)

Build Identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b6pre) Gecko/20100909 Firefox/4.0b6pre ID:20100909041137

Repaint problem of desktop(other application) when exit Fullscreen in Win7 Classic.
The image of the full screen was left.

It does not happen in Wint Aero.

Reproducible: Always

Steps to Reproduce:
1. Start Minefield with new profile
2. Turn Fullscreen (F11)
3. Exit Fullscreen (F11)

Actual Results:
 Repaint problem of desktop.

Expected Results:
 Should paint properly.


Regression window:
Works:
http://hg.mozilla.org/mozilla-central/rev/fe3a1059a92b
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b6pre) Gecko/20100907 Firefox/4.0b6pre ID:20100907064516
Fails:
http://hg.mozilla.org/mozilla-central/rev/3db393b691be
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b6pre) Gecko/20100906 Firefox/4.0b6pre ID:20100907083607
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=fe3a1059a92b&tochange=3db393b691be
(Reporter)

Updated

7 years ago
blocking2.0: --- → ?
Keywords: regression
(Reporter)

Comment 1

7 years ago
This happens Window XP too.
Mozilla/5.0 (Windows NT 5.1; rv:2.0b6pre) Gecko/20100909 Firefox/4.0b6pre ID:20100909041137
(Reporter)

Updated

7 years ago
Summary: Repaint problem of desktop(other application) when exit Fullscreen in Win7 Classic → Repaint problem of desktop(other application) when exit Fullscreen in Win XP/Win7 Classic

Comment 2

7 years ago
Hmm, looks like that was caused by the patch in bug 575855. I'll back it out and reopen.
Blocks: 575855

Updated

7 years ago
blocking2.0: ? → ---

Updated

7 years ago
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
Now I see repaint problem with Aero Glass.  When going into Fullscreen or coming out.
Created attachment 476178 [details]
Win7 Aero Transition problem

This happens going in or coming out of Fullscreen.
You need to log in before you can comment on or make changes to this bug.