Video controls don't show error UI when source element is in error

RESOLVED FIXED

Status

()

Core
Audio/Video
RESOLVED FIXED
7 years ago
7 years ago

People

(Reporter: kinetik, Assigned: cpearce)

Tracking

({regression})

Trunk
x86_64
Linux
regression
Points:
---

Firefox Tracking Flags

(blocking2.0 final+)

Details

Attachments

(2 attachments)

(Reporter)

Description

7 years ago
Created attachment 473809 [details]
testcase

Not sure if this is a controls bug or a regression caused by bug 485288.  The controls work fine if the video-in-error is specified as the video @src.

Testcase attached.  Testcase works correctly in Firefox 3.6, but is broken in trunk nightlies.
(Reporter)

Comment 1

7 years ago
I suspect this is caused by video.error being null, which causes the controls not to show the error state... but I haven't investigated yet.
blocking2.0: --- → ?
Keywords: regression
blocking2.0: ? → final+
(Reporter)

Updated

7 years ago
Assignee: nobody → kinetik
(Reporter)

Comment 2

7 years ago
This is fixed by the patches in bug 505158.
Depends on: 505158
(Assignee)

Comment 3

7 years ago
Bug 505158 has landed, so we now show the gray-error status box with the testcase above. But I just noticed that if I mouseover the video element, we'll display the controls and they never fade out. :(
(Assignee)

Comment 4

7 years ago
I'll take this, as I've fixed a bunch of similar bugs recently.
Assignee: kinetik → chris
Status: NEW → ASSIGNED
(Assignee)

Comment 5

7 years ago
Created attachment 486175 [details] [diff] [review]
Patch

* Ensure the controls don't show when we're unable to load from source children.
Attachment #486175 - Flags: review?(dolske)
Attachment #486175 - Flags: review?(dolske) → review+
(Assignee)

Comment 6

7 years ago
http://hg.mozilla.org/mozilla-central/rev/2bd86fdd9c62
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.