Merge JSStackFrame::ncode with savedpc

RESOLVED DUPLICATE of bug 587707

Status

()

Core
JavaScript Engine
RESOLVED DUPLICATE of bug 587707
8 years ago
8 years ago

People

(Reporter: luke, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
Bug 469713 contains the logic to recompute the savedpc of a frame from its hardware return address.  There is a small impedance mismatch due to the fact that savedpc holds the bytecode pc of the current frame and ncode holds the hw pc of the previous frame.  To simplify matters a bit, I think we should make the two agree about which frame they are talking about.
(Reporter)

Comment 1

8 years ago
Oops, I meant bug 587707.
(Reporter)

Updated

8 years ago
Blocks: 557378
(Reporter)

Updated

8 years ago
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 587707
You need to log in before you can comment on or make changes to this bug.