Browser freezes with unresponsive script warning when attempting to print. Must use force quit on browser.

RESOLVED DUPLICATE of bug 476541

Status

()

Firefox
Tabbed Browser
RESOLVED DUPLICATE of bug 476541
8 years ago
7 years ago

People

(Reporter: Wyn Snow, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.4; en-US; rv:1.9.2.9) Gecko/20100824 Firefox/3.6.9
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.4; en-US; rv:1.9.2.9) Gecko/20100824 Firefox/3.6.9

When attempting to print a page when online at my bank, SOMETIMES the browser hangs/freezes and I get this warning: "? Warning: Unresponsive script
A script on this page may be busy, or it may have stopped responding.
You can stop the script now, or you can continue to see if the script will complete. Script file:///Applications/Firefox.app/Contents/MacOS/modules/NetworkPrioritizer.jsm:175". When this happens, I cannot either continue or cancel the warning alert dialog box (get a beep), AND I cannot either print or cancel the printing. The only thing I can do is force quit. I cannot remember if this happens on other websites. I DO know it has happened several times, but not all the time, while I am online-banking. I believe it has happened on two different accounts on my Mac, which would suggest that it has happened on different websites.

Reproducible: Sometimes

Steps to Reproduce:
1. Click Apple-P to print a page on my printer or using Adobe PDF maker.
2. It gives me the warning message alert dialogue box.

Actual Results:  
3. Browser is frozen and will do nothing more.
4. Must force-quit out of Mozilla Firefox.

Expected Results:  
Should have printed the page, either to my hard-copy printer or to an Adobe PDF file.

Has happened with no theme at all.
(Reporter)

Comment 1

8 years ago
I sometimes get same warning when closing Firefox, but browser doesn't hang. I can simply click either button in the warning dialog box and the browser closes.
moving to tabbed browser for the unresponsive problem.
The can't click on ok/cancel is another bug (modal dialog)
Component: General → Tabbed Browser
QA Contact: general → tabbed.browser

Comment 3

8 years ago
Also happens in FF 3.6.9 running on Intel OS X 10.6.4.

Additional steps to reproduce:

load a page WITHOUT any Javascript, e.g. W3C spec like:

http://dev.w3.org/csswg/css3-color/

* Choose "Print..." from the File menu
* Click the ( PDF v )  -- the button in the lower left of the dialog
* Choose "Save As PDF..."

now just wait a few minutes.

and the "Warning: Unresponsive script A script on this page may be busy..." sheet will appear on the browser window.  

At this point, clicking Save, or Cancel in the Save dialog has noeffect.  You also cannot click on the script warning sheet to dismiss it either. 

Only recourse is to Force Quit.

Comment 4

8 years ago
I have encountered this problem also.
Seems to have been reported as 476541

Updated

7 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 476541
You need to log in before you can comment on or make changes to this bug.