execCommand insertHtml fails with <iframe> in 3.6.9

RESOLVED DUPLICATE of bug 595176

Status

()

RESOLVED DUPLICATE of bug 595176
8 years ago
8 years ago

People

(Reporter: murtlest, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US) AppleWebKit/534.7 (KHTML, like Gecko) Chrome/7.0.517.0 Safari/534.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; sv-SE; rv:1.9.2.9) Gecko/20100824 Firefox/3.6.9 (.NET CLR 3.5.30729)

Working:
embedCode="<strong>hello</strong>";
var res = editDoc.execCommand("insertHtml", false, embedCode);

Not working:

embedCode="<iframe></iframe>";
var res = editDoc.execCommand("insertHtml", false, embedCode);


Worked fine in 3.6.8

Reproducible: Always

Steps to Reproduce:
1. Create iframe with contentEditable=true
2. Use execCommand and try to insert html with another iframe
3.
Actual Results:  
Nothing gets inserted

Expected Results:  
The iframe gets inserted

Same problem on both mac and pc. Always in the 3.6.9 release, never any problems in 3.6.8 or lower.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 595176
You need to log in before you can comment on or make changes to this bug.