After several background update check failures notify the user that they should check if there is a new version available

RESOLVED FIXED in mozilla2.0b7

Status

()

Toolkit
Application Update
RESOLVED FIXED
7 years ago
2 years ago

People

(Reporter: rstrong, Assigned: rstrong)

Tracking

Trunk
mozilla2.0b7
Points:
---
Bug Flags:
in-testsuite +
in-litmus -

Firefox Tracking Flags

(blocking2.0 beta7+)

Details

(Whiteboard: [strings])

Attachments

(4 attachments, 1 obsolete attachment)

Mossop and myself were discussing this today as a way to mitigate complete failure due to bugs like bug 590978.

We could after x number of failures notify the user similar to the way we notify them after 5 cert attribute check failures that there were problems checking for updates and that they should check if there is an update available along with a link to firefox.com.

If we do this strings will be needed.
Created attachment 474461 [details]
screenshot

Mike, I used a string similar to the certificate attribute check error (just one word removed to create this error notification. The string followed by the url is:
Something is preventing &brandShortName; from updating. Please check you have the latest version of &brandShortName; at:
http://www.firefox.com

If you are ok with this ui the only thing I need to know to finish the implementation is how many background check errors in a row before the user should be notified. The counter would be reset after a successful check. I think 10 would be appropriate.
Assignee: nobody → robert.bugzilla
Status: NEW → ASSIGNED
Attachment #474461 - Flags: ui-review?(beltzner)
Created attachment 474462 [details] [diff] [review]
patch in progress - add strings and change the cert page so it can be used for all background errors
btw: we could go with the existing string used for cert attribute check failures without there being an update:
Something is preventing &brandShortName; from updating securely. Please check you have
the latest version of &brandShortName; at:
http://www.firefox.com
What do we consider a failure, here? Will this be shown to users without administration privileges? Also, what happens after this warning is shown - never shown again? Shown after the next five failures?
A failure when checking the update snippet which includes quite a number of errors (system time being off so the cert timestamp is invalid, snippet xml malformed, etc.). This will only be shown when there are consecutive failures of the background check without performing a successful check.

This would be shown to all users that have auto / background checking enabled including those without that are unable to update (e.g. without admin privs or otherwise) since we notify all users when there is an update available even if they are unable to update using the update service.

I would go with a higher number than 5 which was used for the certificate check... perhaps 10 or more? I think it should be safe to show the error again after the "x" number of failures since showing this error should be very rare or due to a bug where the users affected by it are abandoned in that they won't get updates (see bug 590978 for a scenario where we almost ended up in that situation).
If we go with this we'll need strings so requesting blocking... beta 6 please?
blocking2.0: --- → ?
Now that I understand it's just cases where we're unable to get the right information from AUS, and not the case where we're unable to apply the MAR file, I agree that it's a great idea. Let's do it.

I think the string should be:

&brandShortName; is unable to determine if there is an update available. Please make sure that you have the latest version of &brandShortName; from www.firefox.com

(actually, we should make the cert warning error say "Please make sure that you have the latest version of &brandShortName; from www.firefox.com", too!)
blocking2.0: ? → beta6+
Whiteboard: [strings]
Created attachment 474805 [details] [diff] [review]
strings patch
Attachment #474462 - Attachment is obsolete: true
Attachment #474805 - Flags: review?(dtownsend)
Attachment #474461 - Flags: ui-review?(beltzner)
Attachment #474805 - Flags: review?(dtownsend) → review+
Strings pushed to mozilla-central
http://hg.mozilla.org/mozilla-central/rev/d074ed8f120d

Leaving bug open to finish the remaining items
Created attachment 475326 [details] [diff] [review]
patch - implementation rev1
Attachment #475326 - Flags: review?(dtownsend)
Attachment #475326 - Flags: review?(dtownsend) → review+
Created attachment 475341 [details] [diff] [review]
patch ready for import - includes new preference

Received an verbal from Mossop for the pref addition.
Pushed to mozilla-central
http://hg.mozilla.org/mozilla-central/rev/8f4cd741f348
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Flags: in-testsuite+
Flags: in-litmus-
Resolution: --- → FIXED
Target Milestone: --- → mozilla2.0b7
Duplicate of this bug: 394894

Comment 14

2 years ago
This issue seems to be re-appeared on recent nightlies. I can confirm it happens on 42.0a1 (2015-08-07) and (Not quite sure maybe 1-2 days off)42.0a1 (2015-08-03). 

I am currently running 42.0a1 (2015-08-07) 64bit with Windows 10 64b bit if that helps. Installed last two updates manually by downloading the installer from the website.
Flags: needinfo?(robert.strong.bugs)
(In reply to unique.ek from comment #14)
> This issue seems to be re-appeared on recent nightlies. I can confirm it
> happens on 42.0a1 (2015-08-07) and (Not quite sure maybe 1-2 days off)42.0a1
> (2015-08-03). 
> 
> I am currently running 42.0a1 (2015-08-07) 64bit with Windows 10 64b bit if
> that helps. Installed last two updates manually by downloading the installer
> from the website.
Please file a new bug with steps to reproduce.
Flags: needinfo?(robert.strong.bugs)

Comment 16

2 years ago
No steps to reproduce. It pops up the mentioned warning/error screen without any user interaction.
OK, file a new bug providing a general statement of what you are doing and what occurs.
A screenshot would also be handy

Comment 19

2 years ago
I have already opened one, https://bugzilla.mozilla.org/show_bug.cgi?id=1192574.

Comment 20

2 years ago
Folks...I'm not a programmer but experienced user--this only happens in Windows 10 for me (update fails and I get message)--error message is either 'cannot verify' need for update or 'Nightly is up to date' when it's not--I believe it's Windows 10 compatibility error--not the fact that your warning is intermittent but the fact that Windows 10 has it's hooks into everything..so, my comments may be about the bug related to 'not updating' or 'inability to update' rather than the 'intermittent' update error...but I would bet that this is Windows 10 based...screenshot attached...years of testing OSes tells me Microsoft is doing this via Windows 10 but I have not isolated...does not happen in Windows 7 Ultimate...I'm running Enterprise version on Windows 10.

Thanks

Comment 21

2 years ago
(In reply to Robert Sharp from comment #20)
> Folks...I'm not a programmer but experienced user--this only happens in
> Windows 10 for me (update fails and I get message)--error message is either
> 'cannot verify' need for update or 'Nightly is up to date' when it's not--I
> believe it's Windows 10 compatibility error--not the fact that your warning
> is intermittent but the fact that Windows 10 has it's hooks into
> everything..so, my comments may be about the bug related to 'not updating'
> or 'inability to update' rather than the 'intermittent' update error...but I
> would bet that this is Windows 10 based...screenshot attached...years of
> testing OSes tells me Microsoft is doing this via Windows 10 but I have not
> isolated...does not happen in Windows 7 Ultimate...I'm running Enterprise
> version on Windows 10.
> 
> Thanks

I'm running 64-bit version of Windows 10 and manually have to update by downloading full package installer of Nightly build...this has been going on since installation of Windows 10---from beginning.
Please file a new toolkit -> application update bug. Thanks!
You need to log in before you can comment on or make changes to this bug.