Closed Bug 595541 Opened 9 years ago Closed 9 years ago

Rendering glitch on Google gravity

Categories

(Core :: Layout, defect)

x86
All
defect
Not set

Tracking

()

RESOLVED WORKSFORME
Tracking Status
blocking2.0 --- final+

People

(Reporter: renaud.durlin, Unassigned)

References

()

Details

(Keywords: regression)

Attachments

(2 files)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.9) Gecko/20100824 Firefox/3.6.9
Build Identifier: Mozilla/5.0 (Windows NT 5.1; rv:2.0b6pre) Gecko/20100911 Firefox/4.0b6pre

Rendering glitch on Google gravity.

Reproducible: Always

Steps to Reproduce:
1. go to http://mrdoob.com/projects/chromeexperiments/google_gravity
Actual Results:  
Rendering glitches with Firefox/4.0b6pre.

Expected Results:  
Works fine with Firefox 3.6.9.
Attached image Firefox 3.6.9
Attached image Firefox/4.0b6pre
I have also been testing Google Gravity. I figured if I filed a new bug it might be a duplicate of this one. The actual "drop" does work in Firefox 3.6.10, however, in the latest nightly builds the "drop" does not even occur. The rendering issues seemed to have been fixed though.

I decided to start testing older nightly builds to determine the date range from where it worked to when it stopped. 

Tracemonkey
2010-08-31-04-tracemonkey - Experiment works
2010-09-02-04-tracemonkey - Experiment works but does not drop completely
2010-09-02-04-tracemonkey and after - Experiment does not work

Mozilla Central
2010-08-31-04-mozilla-central - Experiment works
2010-09-01-04-mozilla-central and after - Experiment does not work
Fixing a slight typo for Tracemonkey, the builds after 2010-09-04-04-tracemonkey are the ones where the experiment does not work.

After another test the experiment works for the Windows 64-bit nightly: Mozilla/5.0 (Windows NT 6.0; Win64; x64; rv:2.0b7pre)
Gecko/20100916 Firefox/4.0b7pre
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows XP → All
Kevin, for the mozilla-central builds in comment 3, what are the changeset ids?
blocking2.0: --- → ?
Keywords: regression
Hi Boris, are these what you were looking for?

2010-08-31-04-mozilla-central: http://hg.mozilla.org/mozilla-central/rev/1b43ce0bda4f

2010-09-01-04-mozilla-central: http://hg.mozilla.org/mozilla-central/rev/f47972d05473
I wonder if bug 579808 helps with this.
> Hi Boris, are these what you were looking for?

Yes.  I somehow lost track of the bugmail for this bug.  :(

Regression range there seems to be http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=1b43ce0bda4f&tochange=f47972d05473

That said, the drop seems to work for me on trunk... are you still seeing that problem?
Boris, I tested the latest nightly and the drop appears to be working now.
Great, thanks!
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.