Last Comment Bug 595633 - xpcshell: test_clearHistory_shutdown.js fails due to "ReferenceError: TOPIC_GLOBAL_SHUTDOWN is not defined", after bug 580892
: xpcshell: test_clearHistory_shutdown.js fails due to "ReferenceError: TOPIC_G...
Status: VERIFIED FIXED
[Fixed by bug 588651]
: regression
Product: SeaMonkey
Classification: Client Software
Component: Bookmarks & History (show other bugs)
: Trunk
: All All
: -- major (vote)
: seamonkey2.1b1
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
http://mxr.mozilla.org/comm-central/s...
Depends on: 580892 588651
Blocks: SmTestFail
  Show dependency treegraph
 
Reported: 2010-09-12 06:19 PDT by Serge Gautherie (:sgautherie)
Modified: 2010-09-18 23:15 PDT (History)
2 users (show)
bugzillamozillaorg_serge_20140323: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description Serge Gautherie (:sgautherie) 2010-09-12 06:19:51 PDT
http://tinderbox.mozilla.org/showbuilds.cgi?tree=SeaMonkey&maxdate=1283906242&hours=24&legend=0&norules=1
Timeframes:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=3db393b691be&tochange=232553f741a0
(2 unrelated changesets)
http://hg.mozilla.org/comm-central/pushloghtml?fromchange=7fbe67b91630&tochange=3a5ccff4af38
then, iiuc, bug 593855 fixed 15+ failures and "revealed" this one :->

http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1283882467.1283884174.21569.gz
Linux comm-central-trunk debug test xpcshell on 2010/09/07 11:01:07
{
TEST-UNEXPECTED-FAIL | .../test_clearHistory_shutdown.js | test failed (with xpcshell return code: 3), see following log:
TEST-UNEXPECTED-FAIL | (xpcshell/head.js) | ReferenceError: TOPIC_GLOBAL_SHUTDOWN is not defined - See following stack:
JS frame :: /builds/slave/comm-central-trunk-linux-debug-unittest-xpcshell/build/xpcshell/tests/test_suite_places/unit/test_clearHistory_shutdown.js :: run_test :: line 113
...
/builds/slave/comm-central-trunk-linux-debug-unittest-xpcshell/build/xpcshell/head.js:181: TypeError: parts is null
}

http://mxr.mozilla.org/comm-central/search?string=TOPIC_GLOBAL_SHUTDOWN&case=on
Indeed, TOPIC_GLOBAL_SHUTDOWN is not defined anywhere anymore :-/

Bug 580892 removed it: we need to port
http://hg.mozilla.org/mozilla-central/rev/7557b96e9e02
Comment 1 Serge Gautherie (:sgautherie) 2010-09-12 06:23:04 PDT
Hum, it looks like this will probably end up at a bug 588651 duplicate :-/
Comment 2 Justin Wood (:Callek) (Away until Aug 29) 2010-09-12 06:32:42 PDT
Yes, this test has a few changes to port, I'm not yet certain if we need other Front End changes ported on our end though.
Comment 3 Serge Gautherie (:sgautherie) 2010-09-18 23:15:40 PDT
V.Fixed, after bug 588651 check-in, per
http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1284862361.1284863937.13126.gz
Linux comm-central-trunk debug test xpcshell on 2010/09/18 19:12:41

Note You need to log in before you can comment on or make changes to this bug.