Add Android version information to User Agent String

RESOLVED DUPLICATE of bug 1169772

Status

()

RESOLVED DUPLICATE of bug 1169772
8 years ago
3 years ago

People

(Reporter: u295173, Unassigned)

Tracking

unspecified
All
Android
Points:
---

Firefox Tracking Flags

(fennec-)

Details

(URL)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.2.9) Gecko/20100824 Firefox/3.6.9
Build Identifier: 

In http://hacks.mozilla.org/2010/09/final-user-agent-string-for-firefox-4/ the new User Agent string for Gecko based browsers is presented.

What irritates me is that version information about the System is only provided for Windows and OSX. On most (or all?) of the other platforms no information on the version of the operating system is sent.

e.g.
Windows NT 6.1
Intel Mac OS X 10.6

but only

Android
Maemo

It would be very helpful to add the Version of the System.

This is what Webkit based browsers do:
Mozilla/5.0 (Linux; U; Android 2.1; en-us; sdk Build/ERD79) AppleWebKit/530.17 (KHTML, like Gecko) Version/4.0 Mobile Safari/530.17

Reproducible: Always

Actual Results:  
No version infromation on Android, Meego, ... is sent in the User Agent String.

Expected Results:  
Send the Android, Meego, ... Version in the User Agent String.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Other → Android
(Reporter)

Updated

8 years ago
tracking-fennec: --- → ?
we don't see a need for including the OS version
tracking-fennec: ? → 2.0-

Comment 2

8 years ago
Hi

It would be really helpful to know what Android version Firefox is running on.
Some people, like me, do see important needs.
For example if you want to propose a download, there are enormous OS differents between 1.0 and 2.0, and even minor versions like 2.0 and 2.3
And it's going to be the same for upcoming Android 3.0

Comment 3

8 years ago
I'm less concerned about the Android version info than the lack of reporting DeviceModel in the user agent. 

1./ From the Android 2.3 Compatibility Definition it is clear that Android mandates reporting the DeviceModel - (http://source.android.com/compatibility/android-2.3-cdd.pdf):

The user agent string reported by the WebView MUST be in this format:

Mozilla/5.0 (Linux; U; Android $(VERSION); $(LOCALE); $(MODEL) Build/$(BUILD)) AppleWebKit/533.1 (KHTML, like
Gecko) Version/4.0 Mobile Safari/533.1

2./ IE for Windows Phone mandates DeviceModel section - 

3./ Device manufactures (e.g. Nokia0 typically includes DeviceModel.

I do appreciate the thought leadership of simplifying the User Agent string, but I think there is a real need for the DeviceModel in the user agent string.

Updated

8 years ago
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME

Comment 4

8 years ago
sorry wontfix.

putting detailed platform info in the ua is generally a bad idea.
Resolution: WORKSFORME → WONTFIX
(Reporter)

Comment 5

8 years ago
> putting detailed platform info in the ua is generally a bad idea.
Sorry. This reason is trash! On all other platforms you put Version info in the UA. And all othe browsers do it. Since when is putting the OS version, that probably hundreds of million other users share with you is a bad idea? Come on!
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---

Comment 6

7 years ago
How else would we determine if the device supports Flash or not? (Android 2.2+ vs. Android 2.1 and below)

Comment 7

5 years ago
I support the idea that like all others browsers, Firefox should send the device model information in the user agent header field.
For example with Chrome I get for my S4 mini:
'Mozilla/5.0 (Linux; Android 4.2.2; fr-fr; SAMSUNG GT-I9195 Build/JDQ39) AppleWebKit/535.19 (KHTML, like Gecko) Version/1.0 Chrome/18.0.1025.308 Mobile Safari/535.19'
With Opera 'Mozilla/5.0 (Linux; Android 4.2.2; GT-I9195 Build/JDQ39) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/31.0.1650.57 Mobile Safari/537.36 OPR/18.0.1290.67495'
where with Firefox I only get 'Mozilla/5.0 (Android; Mobile; rv:25.0) Gecko/25.0 Firefox/25.0'
Status: REOPENED → RESOLVED
Last Resolved: 8 years ago3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1169772
You need to log in before you can comment on or make changes to this bug.