Last Comment Bug 595734 - Move nsSVGUtils::ConvertToSurfaceSize back to nsSVGUtils.cpp, once we're in a libxul-only world
: Move nsSVGUtils::ConvertToSurfaceSize back to nsSVGUtils.cpp, once we're in a...
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Layout (show other bugs)
: Trunk
: All All
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
http://hg.mozilla.org/mozilla-central...
Depends on: 276431 require-libxul 649429
Blocks:
  Show dependency treegraph
 
Reported: 2010-09-12 16:54 PDT by Daniel Holbert [:dholbert]
Modified: 2011-04-25 07:41 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Daniel Holbert [:dholbert] 2010-09-12 16:54:50 PDT
Bug 276431 moved nsSVGUtils::ConvertToSurfaceSize from the .cpp file to the .h file, so that it can be called from imagelib in non-libxul builds:
http://hg.mozilla.org/mozilla-central/annotate/827cba9e2671/layout/svg/base/src/nsSVGUtils.h#l425

Once we move to a libxul-only world, that method can & should move back to the .cpp file.
Comment 1 :Ms2ger (⌚ UTC+1/+2) 2011-04-25 00:35:24 PDT
This was done in bug 649429, but I can't dupe it because I can't access that bug. Could you?
Comment 2 Daniel Holbert [:dholbert] 2011-04-25 07:41:57 PDT
Thanks for pointing that out.  Resolving as FIXED with a dependency on that bug.  (Not duping since the main thrust of that bug was completely different from this.)

The checkin from that bug that fixed this was:
http://hg.mozilla.org/mozilla-central/rev/33b198be1aa3

Note You need to log in before you can comment on or make changes to this bug.