Tabs misaligned in bookmark Properties dialog

RESOLVED FIXED

Status

SeaMonkey
Bookmarks & History
P3
trivial
RESOLVED FIXED
17 years ago
13 years ago

People

(Reporter: Nick Meara, Assigned: shliang)

Tracking

({classic})

Trunk
PowerPC
Mac System 8.6
classic

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Overview description:
=====================
The tab separators are misaligned in the Properties dialog of a bookmark. This
applies to the Classic theme only and is most noticable on the Macintosh.

Reproducible:
=============
Always

Steps to reproduce:
===================
1) Choose Manage Bookmarks... from the Bookmarks menu to open the Manage
   Bookmarks window.
2) Select a bookmark and choose Properties... from the Edit menu to display the
   Properties dialog for the bookmark.

Actual result:
==============
The Properties dialog is displayed. The tabs in the tab widget are placed 1
pixel higher than they should be.

Expected result:
================
The bottom of the tabs aligns with the top of the tab widget box.

Build date and platform:
========================
Occurs on 2000-11-08-20 build on Mac OS 8.6 with Classic theme only.

Additional builds and platforms:
================================
I think that the bug is also present on 2000-11-08-04 build on Windows 95 with
the Classic theme, but it's not as obvious as the Mac problem.
Netscape Nav Triage Team - reassigning to hangas
Assignee: ben → hangas
(Reporter)

Comment 2

17 years ago
I think that I might have a fix for this on the Mac. In
classic:global:tabcontrol.css adding the declaration margin-bottom: -1px; to the
tab rule appears to align the tabs correctly with the top of the panel.

tab { 
  -moz-binding      : url(chrome://global/skin/classicBindings.xml#tab);
  color             : #000000; 
  padding           : 0px;
  margin-bottom     : -1px;
}

There aren't any obvious side effects that I can see, but this same change
doesn't fix the problem on the Windows version of Classic.

Updated

17 years ago
Keywords: classic

Updated

17 years ago
Summary: [Classic] Tabs misaligned in bookmark Properties dialog → Tabs misaligned in bookmark Properties dialog

Comment 3

17 years ago
Sending to Andrew
Assignee: hangas → andreww
Keywords: nsbeta1
Summary: Tabs misaligned in bookmark Properties dialog → Mac Classic - Tabs misaligned in bookmark Properties dialog

Comment 4

17 years ago
Themes Triage Team marking nsbeta1-
Keywords: nsbeta1 → nsbeta1-

Updated

17 years ago
Status: NEW → ASSIGNED

Updated

17 years ago
Blocks: 91504

Comment 5

16 years ago
she's working on tabs -->shliang
Assignee: andreww → shliang
Status: ASSIGNED → NEW
Summary: Mac Classic - Tabs misaligned in bookmark Properties dialog → Tabs misaligned in bookmark Properties dialog
(Assignee)

Comment 6

16 years ago
i don't see this on mac or win - doesn't seem to be a problem anymore
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
(Assignee)

Comment 7

16 years ago
woops wrong bug
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---

Comment 8

16 years ago
*** Bug 120497 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 9

16 years ago
fixed
Status: REOPENED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → FIXED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.