Closed Bug 595957 Opened 10 years ago Closed 10 years ago

Sept 10-12, Spike in Firefox Crashes for Russian Users [@ nsDiskCacheDevice::OpenDiskCache() ]

Categories

(Core :: Networking: Cache, defect)

x86
Windows XP
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 598007

People

(Reporter: chofmann, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: crash, Whiteboard: [explosive])

Crash Data

spike in crashes with this signature over the last few days

we were running about 30-90 crashes per day, but yesterday we saw over 3000.  seems to be spread across many releases.


20100907 53  ,31 3.6.8,13 4.0b4,4 3.5.11,3 3.6.6,1 3.6.9,1 3.6.7,
20100908 52  ,40 3.6.8,6 3.6.9,4 3.5.11,1 4.0b3,1 3.5.12,
20100909 47  ,15 3.6.8,13 3.6.9,6 4.0b5,5 3.5.11,4 3.6.3,2 4.0b4,1 3.6.6,
20100910 724  ,263 3.6.9,112 3.6.8,52 4.0b5,46 3.6,45 3.0.19,28 3.6.3,27 3.5.12
20100911 1938  ,985 3.6.9,212 3.6.8,122 3.0.19,76 4.0b5,74 3.5.12,73 3.6,
20100912 3088  ,1313 3.6.9,404 3.6.8,219 4.0b5,174 3.0.19,139 3.6,128 3.5.12

checking --- nsDiskCacheDevice::OpenDiskCache.. 20100912-crashdata.csv
found in: 3.6.9 3.6.8 4.0b5 3.0.19 3.6 3.5.12 3.6.3 4.0b4 3.6.6 3.5.11 3.0.1 3.5.3 4.0b6pre 3.5.2 3.1b3 3.5.5 3.5.6 3.0.5 3.0.10 4.0b2 3.5 3.0.6 3.0.3 3.5.9 
3.0b4 3.6.2 3.0.7 3.0.8 4.0b5pre 3.0.9 3.0.4 3.5.1 3.5.7 3.0 4.0b3 3.6.7 3.6.4 3.6.3plugin1 3.5.10 3.7a2 3.0.11 3.7a6pre 3.7a3 3.7a1 3.6b2 3.0b1 4.0b1 3.6b4 
3.5b99 3.5.4 3.1b2 3.0.18 3.0.15 3.0.13
release total-crashes
              nsDiskCacheDevice::OpenDiskCache.. crashes
                         pct.
all     312041  3088    0.00989614
3.6.9   146961  1313    0.00893434
3.6.8   44648   404     0.00904856
4.0b5   37313   219     0.00586927
3.0.19  7628    174     0.0228107
3.6     5896    139     0.0235753
3.5.12  10661   128     0.0120064
3.6.3   10422   105     0.0100748
4.0b4   5066    86      0.0169759
3.6.6   6835    51      0.00746159
3.5.11  4828    38      0.00787075
3.0.1   1227    38      0.0309698
3.5.3   780     31      0.0397436
4.0b6pre3625    30      0.00827586
3.5.2   682     29      0.042522

stack looks like

Frame  	Module  	Signature [Expand]  	Source
0 		@0x4edbc10 	
1 	xul.dll 	nsDiskCacheDevice::OpenDiskCache 	netwerk/cache/nsDiskCacheDevice.cpp:925
2 	xul.dll 	nsDiskCacheDevice::Init 	netwerk/cache/nsDiskCacheDevice.cpp:381
3 	xul.dll 	nsCacheService::CreateDiskDevice 	netwerk/cache/nsCacheService.cpp:1031
4 	xul.dll 	nsCacheService::SearchCacheDevices 	netwerk/cache/nsCacheService.cpp:1444
5 	xul.dll 	nsCacheService::ActivateEntry 	netwerk/cache/nsCacheService.cpp:1353
6 	xul.dll 	nsCacheService::ProcessRequest 	netwerk/cache/nsCacheService.cpp:1216
7 	xul.dll 	nsProcessRequestEvent::Run 	netwerk/cache/nsCacheService.cpp:639
8 	xul.dll 	nsThread::ProcessNextEvent 	xpcom/threads/nsThread.cpp:547
9 	xul.dll 	nsThread::ThreadFunc 	xpcom/threads/nsThread.cpp:263
10 	nspr4.dll 	_PR_NativeRunThread 	nsprpub/pr/src/threads/combined/pruthr.c:426
11 	nspr4.dll 	pr_root 	nsprpub/pr/src/md/windows/w95thred.c:122
12 	mozcrt19.dll 	_callthreadstartex 	obj-firefox/memory/jemalloc/crtsrc/threadex.c:348
13 	mozcrt19.dll 	_threadstartex 	obj-firefox/memory/jemalloc/crtsrc/threadex.c:326
14 	kernel32.dll 	BaseThreadStart 	

more reports at

http://crash-stats.mozilla.com/report/list?signature=nsDiskCacheDevice::OpenDiskCache%28%29

stack runs through code that changed in Bug 513008 - Eliminate synchronous reads from cache. r=jduell,sdwilsh sr=shaver a2.0=blocking
but since this affects old/stable branches seems unlikely to be connected.

appears to be start up related, and affects users repeatedly.

Correlation to startup or time of session
3088 total crashes for nsDiskCacheDevice::OpenDiskCache.. on 20100912-crashdata.csv
3032 startup crashes inside 30 sec.
3087 startup crashes inside 3 min.
2411 repeated crashes inside 3 min. of last crash

some dups are spotted in the 3000, and its 99% winXP but volume seem to high enough that this is a wider spread problem.

all of the comments are non-english so far.  


   Исправьте!!!

   выдает ошибку и не запускает мозилу
not a strong correlation to any addons.

15% (179/1222) vs.   3% (4544/139394) yasearch@yandex.ru (Yandex.Bar, https://addons.mozilla.org/addon/3495)
14% (176/1222) vs.   2% (2617/139394) {37964A3C-4EE8-47b1-8321-34DE2C39BA4D}

some 100% module correlations but they look to be windows system .dlls.
http://crash-stats.mozilla.com/report/index/80371bbf-412e-4d30-a759-bf8092100912
Summary: Sept 10-12, Spike in Firefox Crashes [@ nsDiskCacheDevice::OpenDiskCache() ] → Sept 10-12, Spike in Firefox Crashes for Russian Users [@ nsDiskCacheDevice::OpenDiskCache() ]
it seems that none of the comments provide any tip. The repeated terms in the comments are "incorrect" and "Does not include -__-;;" but it doesn't make too much sense unfortunately.

CC'ing our Russian leaders in case they find anything meaningful there.
FWIW, in last few days we (russian community) have received a bunch of support requests about sites distributing false updates for Firefox and Windows, containing trojans. These trojans after install demand to send SMS to premium rate numbers to "activate updates".
BTW, one of these sites ( http://zashitapc.ru/?tmpbrid=10489 ), figures in comment 1
Another example from support mail is http://firefox2.update26.info/
I'm not sure if trojans can be cause of Firefox crashes, but it's only unusual activity that I'm aware of.
volume continues high on this.  sept 15 was a socorro downtime.

date     crashes at
         nsDiskCacheDevice::OpenDiskCache
20100901 121
20100902 99
20100903 50
20100904 55
20100905 30
20100906 67
20100907 53
20100908 52
20100909 47
20100910 724
20100911 1938
20100912 3088
20100913 4188
20100914 2556
20100915 0
20100916 750
20100917 1458
20100918 2331
20100919 2974
20100920 4270
20100921 3604
20100922 3805
20100923 3418
20100924 2678
20100925 4520
20100926 5186
This appears likely to be caused by the same malware mentioned in bug 598007 comment 60.

If anyone experiencing this bug can try the instructions listed in the blog post mentioned there, that would be great.

No obvious way to blacklist the malware (no dll name that's specific to it).  Marking as dupe unless evidence to the contrary shows up.

Spike appears to have been transient.
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 598007
has this been verified to be a dupe of bug 598007?


(In reply to comment #6)
> This appears likely to be caused by the same malware mentioned in bug 598007
> comment 60.
> 
> If anyone experiencing this bug can try the instructions listed in the blog
> post mentioned there, that would be great.
> 
> No obvious way to blacklist the malware (no dll name that's specific to it). 
> Marking as dupe unless evidence to the contrary shows up.
> 
> Spike appears to have been transient.
> 
> *** This bug has been marked as a duplicate of bug 598007 ***

not sure what you mean by transient, but it's a solid crash for firefox 3.6.13.
all the comments are in german or russian.

all thunderbird crash comments are in german
https://crash-stats.mozilla.com/report/list?product=Thunderbird&query_search=signature&query_type=exact&query=nsDiskCacheDevice%3A%3AOpenDiskCache%28%29&date=01%2F07%2F2011%2013%3A27%3A40&range_value=4&range_unit=weeks&hang_type=any&process_type=any&plugin_field=&plugin_query_type=&plugin_query=&do_query=1&admin=&signature=nsDiskCacheDevice%3A%3AOpenDiskCache%28%29

pretty much also true of nsDiskCacheMap::OpenBlockFiles() - bug 616198
TB https://crash-stats.mozilla.com/report/list?product=Thunderbird&query_search=signature&query_type=exact&query=nsDiskCacheMap%3A%3AOpenBlockFiles%28%29&date=12%2F01%2F2010%2011%3A43%3A41&range_value=4&range_unit=weeks&hang_type=any&process_type=any&plugin_field=&plugin_query_type=&plugin_query=&do_query=1&admin=&signature=nsDiskCacheMap%3A%3AOpenBlockFiles%28%29
FF https://crash-stats.mozilla.com/report/list?product=Firefox&query_search=signature&query_type=exact&query=nsDiskCacheMap%3A%3AOpenBlockFiles%28%29&date=01%2F07%2F2011%2013%3A34%3A36&range_value=4&range_unit=weeks&hang_type=any&process_type=all&plugin_field=&plugin_query_type=&plugin_query=&do_query=1&admin=&signature=nsDiskCacheMap%3A%3AOpenBlockFiles%28%29
Summaries of comments:

TB: crashes on starting Thunderbird

nsDiskCacheMap::OpenBlockFiles() - bug 616198

TB (seem to be only four users with comments)
- crashes on reading first mail
- one report of it crashing later on TB startup
- one report of TB and Fx crashing on startup
- one report of the crash after installing a persona

Fx (not much useful)
- one report of crash during browsing
- one report of unwanted popups before first crash (malware?)
Crash Signature: [@ nsDiskCacheDevice::OpenDiskCache() ]
You need to log in before you can comment on or make changes to this bug.