js_GetPropertyHelper() called too many times for access-binary-trees.js

RESOLVED DUPLICATE of bug 589398

Status

()

Core
JavaScript Engine
RESOLVED DUPLICATE of bug 589398
7 years ago
7 years ago

People

(Reporter: njn, Assigned: njn)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Assignee)

Description

7 years ago
js_GetPropertyHelper() is called 42,101 times for access-binary-trees.js.  Almost all of them are due to this JM code:

JSBool JS_FASTCALL
stubs::NewObject(VMFrame &f, uint32 argc)
{
    JSContext *cx = f.cx;
    Value *vp = f.regs.sp - (argc + 2);

    JSObject *funobj = &vp[0].toObject();
    JS_ASSERT(funobj->isFunction());

    jsid id = ATOM_TO_JSID(cx->runtime->atomState.classPrototypeAtom);
    if (!funobj->getProperty(cx, id, &vp[1]))
        THROWV(JS_FALSE);


jorendorff says there should be some way to avoid this -- a PIC or something.
Blocks: 578133
(Assignee)

Updated

7 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 589398
You need to log in before you can comment on or make changes to this bug.