throbber never stops running; pegs CPU!!

VERIFIED DUPLICATE of bug 39310

Status

()

Core
Networking
P3
normal
VERIFIED DUPLICATE of bug 39310
17 years ago
17 years ago

People

(Reporter: Henrik Gemal, Assigned: Gagan)

Tracking

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
if you go to:
http://www.britneyspears.com/welcome.html
the throbber (the animated mozilla) never stops.
the page says "document: done"

trunk build 20001108

Comment 1

17 years ago
Hmm.. works for me.
(Reporter)

Comment 2

17 years ago
Which build and os?

Comment 3

17 years ago
Hehe...Britney Spears...throbber...

never mind...

Could be a related to bug 39310. 

Comment 4

17 years ago
I've seen this happen, too, although it's not always reproducible on the same
site.  One interesting point: I saw this on http://www.zdnet.com/zdnn today and
noticed that one of the ad graphics at the top of the page hadn't loaded yet.  I
looked at Page Info to find out where the image was coming from.  And oddly
enough, in the Page Info dialog, when I clicked on the corresponding image name,
the image *did* appear!  So for some reason, the image is available, but the
main browser window wouldn't show it, and thus (I think) kept the throbber going.

Comment 5

17 years ago
This is reproducable about 9 times out of 10 on the results of a bugzilla query
(which doesn't have any animated gifs) The page finishes loading, but the
throbber doesn't stop.

On the console, I get: "WARNING: not calling OnDataAvailable, file
nsAsyncStreamListener.cpp, line 406" each time, which may or may not be related.
I don't get this error on the britney spears URL, which does have an animated
gif, but I do get it on slashdot, where the throbber sometimes (but not always)
doesn't stop. Slashdot does have animated gif banners though. Same with the
zdnet url.

Is this a separate bug to the animated gif one, or is the warning message not
related?

I'm on Linux, so changing OS to ALL.
OS: Windows 2000 → All

Comment 6

17 years ago
I have a hunch that the Warning from nsAsyncStreamListener is related to this
problem.  This happens when there is a failed status on the channel... not
calling OnDataAvailable in this case results in not sending notifications up
stream.  I'll have to investigate this some more...

Comment 7

17 years ago
Afer spending yesterday doing qutie a few web searches for maths stuff (now that
mathworld is down), I think theres some relation between this bug and loading
dynamic pages (search engine results, slashdot, kuro5hin, bugzilla results,
etc). It almost never happens on static pages, and when it does there are often
animated gifs involved.

Comment 8

17 years ago
Seems that when the throbber is in this state, mozilla pegs the CPU!  And, it
is not just after the page loads, but also while waiting for the page to
download.  The CPU is pegged even before we get any socket traffic!  The 
not calling OnDataAvailable warning results from a NS_ERROR_ABORT status on the
channel.  I want to understand why/how this is being set... it might reveal
something about the CPU usage as well.

Comment 9

17 years ago
updating the summary...
Summary: throbber never stops running → throbber never stops running; pegs CPU!!

Comment 10

17 years ago
I've just noticed that I get the WARNING with about:blank (on startup, or typing
it into the location bar). The throbber does stop though - it doesn't even look
like it starts in the first place.

Comment 11

17 years ago
I tried this with dynamic content: I have a simple test at
  http://www.inf.bme.hu/~hyp-x/test.cgi
(originaly created for an other bug).
It contains no images at all.

It may be so that this bug occurs when the content length is unknown.
The bug is also PROXY related, when I set "Direct connection to the Internet"
it works okay for my page.

The Britney page on the other hand behaves badly even with direct connection
set, that may be due to animated gif's. So I think this is at least two
different bug.

Btw. I tested 2000-11-11-08 on Win98SE.

Comment 12

17 years ago
OK, it looks like this bug is partially fixed in the netscape RTM branch.  That
is all symptoms, except the original one, are fixed in the RTM branch.  Once
the two get in sync, we should hopefully see many of the symptoms go away.  That
being said, let's focus on the fact that the throbber doesn't stop on pages
containing an animated GIF.  Does anyone know if this is simply a feature?  NS
4.7 doesn't behave this way, so probably it is wrong, but maybe this was
intentional???

Comment 13

17 years ago
The animated gif bug was bug 39310 (mentioned in the 2000-11-09 08:20 comment).
That bug now covers this issue (The summary has been changed to "progressmeter
and throbber do not stop spinning after submitting a bugzilla comment"), so this
should possibly be marked as a dup of that.

I hope the behaviour is not intentional. OTOH bug 39310 is marked FUTURE, so...
(Assignee)

Updated

17 years ago
Keywords: verifyme

Comment 14

17 years ago
Happens to me on 12/13 build.

Possible clue: throbber stops and 'stop' button goes out when I click the scrollbar.

Comment 15

17 years ago
Marking duplicate finally

*** This bug has been marked as a duplicate of 39310 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Keywords: verifyme
Resolution: --- → DUPLICATE
verified dup.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.