Closed Bug 596169 Opened 9 years ago Closed 9 years ago

<summary> should implicitly close <p>

Categories

(Core :: HTML: Parser, defect, P2)

defect

Tracking

()

RESOLVED FIXED
Tracking Status
blocking2.0 --- betaN+

People

(Reporter: hsivonen, Assigned: hsivonen)

References

()

Details

Attachments

(1 file)

The spec changed to require <summary> to implicitly close <p>. (I don't like implicit <p> closing, but not gonna fight against this one.)
Depends on: 559023
Priority: -- → P2
Duplicate of this bug: 596171
Assignee: nobody → hsivonen
Status: NEW → ASSIGNED
Attachment #480890 - Flags: review?(jonas)
Comment on attachment 480890 [details] [diff] [review]
Make <summary> and <figcaption> behave per spec. Remove <datagrid>.

rs=me
Attachment #480890 - Flags: review?(jonas) → review+
Nominating for 2.0 since this an HTML5-correctness bug that's very visible in the best known HTML5 parsing test suite.
blocking2.0: --- → ?
blocking2.0: ? → betaN+
http://hg.mozilla.org/mozilla-central/rev/df1d1ff6b489
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Flags: in-testsuite+
You need to log in before you can comment on or make changes to this bug.