crash at end of profile manager..

VERIFIED DUPLICATE of bug 6005

Status

Core Graveyard
Profile: BackEnd
P3
normal
VERIFIED DUPLICATE of bug 6005
19 years ago
2 years ago

People

(Reporter: chris hofmann, Assigned: mcmullen)

Tracking

Trunk
x86
Windows 95

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
Crash on win95 and other platforms after filling out
profile info, and before apprunner starts.

 Call Stack:    (Signature = js_Invoke 30827f5f)
  js_Invoke [d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 698]
  js_Interpret [d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 2200]
  js_Invoke [d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 671]
  js_Interpret  [d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 2200]
  js_Invoke [d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 671]
  js_Interpret [d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 2200]
  js_Invoke [d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 671]
  js_CallFunctionValue [d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 736]
  JS_CallFunctionValue
[d:\builds\seamonkey\mozilla\js\src\jsapi.c, line 2439]
  nsJSEventListener::HandleEvent
[d:\builds\seamonkey\mozilla\dom\src\events\nsJSEventListener.cpp, line 98]
RAPTORHTML.DLL + 0x77f36 (0x014e7f36)
RAPTORHTML.DLL + 0xdd74 (0x0147dd74)
RAPTORHTML.DLL + 0x95d9c  (0x01505d9c)
RAPTORHTML.DLL + 0x78bf4  (0x014e8bf4)
RAPTORHTML.DLL + 0x78796  (0x014e8796)
RAPTORHTML.DLL + 0x1e6f9  (0x0148e6f9)
RAPTORVIEW.DLL + 0x1d4c  (0x01f71d4c)
RAPTORVIEW.DLL + 0x1d12  (0x01f71d12)
RAPTORVIEW.DLL + 0x1d12  (0x01f71d12)
RAPTORVIEW.DLL + 0x1d12  (0x01f71d12)

kipp also writes:
OK, I found out how to make it work.

1. You have to fill out *every* field in the profile setup, including
the ones that it tells you don't have to.

2. After entering your outgoing SMTP server you have to hit Exit.

Then when you restart the apprunner comes up. I suspect that #1 is the
critical item.

Comment 1

19 years ago
This is what I was seeing for the crash last night.  Seems a bit more accurate
than the Win95 stack trace.  This was on Solaris of course.

****  Purify instrumented ./apprunner.pure (pid 16012)  ****
NPW: Null pointer write:
  * This is occurring while in:
        memcpy         [rtlib.o]
        CharImpl::write(const char*,unsigned int) [nsIStringStream.cpp:236]
        BasicStringImpl::Write(const char*,unsigned int,unsigned int*)
[nsIStringStream.cpp:104]
        nsOutputStream::write(const void*,int) [nsFileStream.cpp:109]
        nsOutputStream::operator <<(const char*) [nsFileStream.cpp:131]
        operator <<(nsOutputStream&,const nsPersistentFileDescriptor&)
[nsFileSpec.cpp:1153]
        nsProfile::SetProfileDir(const char*,const nsFileSpec&)
[nsProfile.cpp:510]
        nsProfile::CreateNewProfile(char*) [nsProfile.cpp:552]
        nsProfileCore::CreateNewProfile(const nsString&) [nsProfileCore.cpp:345]
        ProfileCoreCreateNewProfile(JSContext*,JSObject*,unsigned
int,long*,long*) [nsJSProfileCore.cpp:301]
        js_Invoke      [jsinterp.c:650]
        js_Interpret   [jsinterp.c:2199]
        js_Invoke      [jsinterp.c:666]
        js_Interpret   [jsinterp.c:2199]
        js_Invoke      [jsinterp.c:666]
        js_Interpret   [jsinterp.c:2199]
        js_Invoke      [jsinterp.c:666]
        js_CallFunctionValue [jsinterp.c:735]
        JS_CallFunctionValue [jsapi.c:2437]
        nsJSEventListener::HandleEvent(nsIDOMEvent*) [nsJSEventListener.cpp:97]

nsEventListenerManager::HandleEvent(nsIPresContext&,nsEvent*,nsIDOMEvent**,unsig
ned int,nsEventStatus&) [nsEventListenerManager.cpp:561]

nsGenericElement::HandleDOMEvent(nsIPresContext&,nsEvent*,nsIDOMEvent**,unsigned
int,nsEventStatus&) [nsGenericElement.cpp:766]

nsHTMLButtonElement::HandleDOMEvent(nsIPresContext&,nsEvent*,nsIDOMEvent**,unsig
ned int,nsEventStatus&) [nsHTMLButtonElement.cpp:368]

nsEventStateManager::CheckForAndDispatchClick(nsIPresContext&,nsMouseEvent*,nsEv
entStatus&) [nsEventStateManager.cpp:558]

nsEventStateManager::PostHandleEvent(nsIPresContext&,nsGUIEvent*,nsIFrame*,nsEve
ntStatus&,nsIView*) [nsEventStateManager.cpp:162]
        PresShell::HandleEvent(nsIView*,nsGUIEvent*,nsEventStatus&)
[nsPresShell.cpp:2012]
        nsView::HandleEvent(nsGUIEvent*,unsigned int,nsEventStatus&)
[nsView.cpp:829]
        nsView::HandleEvent(nsGUIEvent*,unsigned int,nsEventStatus&)
[nsView.cpp:816]
        nsView::HandleEvent(nsGUIEvent*,unsigned int,nsEventStatus&)
[nsView.cpp:816]
        nsView::HandleEvent(nsGUIEvent*,unsigned int,nsEventStatus&)
[nsView.cpp:816]
  * Writing 8 bytes to 0x0

Comment 2

19 years ago
Is this with the M5 or M6 build?

Updated

19 years ago
Assignee: gayatrib → racham
Target Milestone: M6

Comment 3

19 years ago
This is an M6 bug.

Updated

19 years ago
Assignee: racham → mcmullen

Comment 4

19 years ago
Reassigning to John (McMullen).
(Assignee)

Comment 5

19 years ago
Accepting bug
(Assignee)

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE
(Assignee)

Comment 6

19 years ago
Aha! This is a duplicate of 6005. Marking it so.


*** This bug has been marked as a duplicate of 6005 ***

Updated

19 years ago
Status: RESOLVED → VERIFIED

Updated

18 years ago
Component: Profile Manager → Profile Manager BackEnd

Comment 7

18 years ago
Moving all Profile Manager bugs to new Profile Manager Backend component.
Profile Manager component to be deleted.
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.