All major OS X browsers (Safari, Chrome, Opera) except from Firefox provide a "new window" option in the right-click menu in dock

RESOLVED DUPLICATE of bug 415463

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 415463
8 years ago
8 years ago

People

(Reporter: mgol, Unassigned)

Tracking

3.6 Branch
x86_64
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.2.9) Gecko/20100825 Ubuntu/10.04 (lucid) Firefox/3.6.9
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; pl; rv:1.9.2.9) Gecko/20100824 Firefox/3.6.9

All major OS X browsers (Safari, Chrome, Opera) except from Firefox provide a "new window" option in the right-click menu in dock. Opera also has a "new tab" option and both Chrome and Opera have a "new private window" choice. I guess the last one is impossible to implement in Firefox as it currently doesn't support private and non-private windows at the same time, but a "new window" option seems to be OS X standard so it should be included in Firefox, too.

Reproducible: Always

Steps to Reproduce:
1. Open Firefox
2. Right-click Firefox icon in the dock
Actual Results:  
There is no "new window" option.

Expected Results:  
There should be a "new window" option.
(Reporter)

Updated

8 years ago
Version: unspecified → 3.6 Branch
This will be in Firefox 4.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 415463
You need to log in before you can comment on or make changes to this bug.