select styling vanishes if border-radius and overflow-x are set on the parent form.

RESOLVED DUPLICATE of bug 595842

Status

()

RESOLVED DUPLICATE of bug 595842
8 years ago
8 years ago

People

(Reporter: bugs, Unassigned)

Tracking

({regression})

Trunk
x86
Windows XP
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment, 1 obsolete attachment)

915 bytes, application/xhtml+xml
Details
(Reporter)

Description

8 years ago
This does not happen with Firefox 3.6 - Firefox 4 only.
Could be related to the recent enabling of border-radius.

The link is to a reduced testcase of an actual site where selects became invisible.

Again apologies, this should probably be filed in Core - still that javascript bug with the template, but this bug seemed reasonably significant, and I have a bad habit of forgetting to file when I can do so from a computer with javascript.
Assignee: marcia → nobody
Component: Bugzilla: Keywords & Components → Style System (CSS)
Product: mozilla.org → Core
QA Contact: timeless → style-system
Version: other → Trunk
Could you please attach a testcase?
Keywords: 4xp, regression
Keywords: 4xp
(Reporter)

Comment 2

8 years ago
Created attachment 475550 [details]
Demo of invisible select lists in FF4
(Reporter)

Comment 3

8 years ago
To elaborate on the testcase, if you inspect the form element in Firebug, you can toggle off either the border-radius or the overflow-x rule to see the selects reappear.

Toggle the rule on again, and they vanish.
I see two drop-down-lists in that testcase.  What OS are you on?

Mozilla/5.0 (X11; Linux x86_64; rv:2.0b7pre) Gecko/20100914 Firefox/4.0b7pre
(Reporter)

Comment 5

8 years ago
Huh. I'd assumed it was generic. Go figure.

Mozilla/5.0 (Windows NT 5.1; rv:2.0b7pre) Gecko/20100914 Firefox/4.0b7pre

Just retested in a clean profile after a moment of panic.

You're right though. Does not impact my OSX or Linux machines, even if I set a border: 1px solid black; just to turn off native styling.
OS: Other → Windows XP
Hardware: Other → x86
Does this depend on whether graphics acceleration is turned on on Windows?
blocking2.0: --- → ?
(Reporter)

Comment 7

8 years ago
I set:
layers.accelerate-all;false
layers.accelerate-none;true

And I still saw it - is there something else I should set?

Also reproducible in Windows Vista in a test VM BTW.
OK.  Next thing is probably finding a regression range....
Oh, also try setting mozilla.widget.render-mode to 0?
(Reporter)

Comment 10

8 years ago
No difference between -1, 0 and 6 for render-mode
(Reporter)

Comment 11

8 years ago
Created attachment 475576 [details]
Demo of invisible select lists in FF4 for Windows

Adding -moz-border-radius in case the regression range carries me beyond the recent enabling of border-radius.
Attachment #475550 - Attachment is obsolete: true
(Reporter)

Comment 12

8 years ago
Problem is NOT visible in 2010-09-08 prior to the push of border-radius.

It exists regardless of whether a page is using -moz-border-radius or border-radius which is not really a surprise I suppose.
http://m8y.org/tmp/testcase197.xhtml (page using -moz-border-radius)
(Reporter)

Comment 13

8 years ago
Problem appears between 2010-09-09 and 2010-09-10
Sooo, between:
http://hg.mozilla.org/mozilla-central/rev/8e0fce7d5b49
and
http://hg.mozilla.org/mozilla-central/rev/79d0beec27b5

And just as a guess, the most recent border-radius fixes? :)
Yes, I bet.
Blocks: 459144
(Reporter)

Comment 16

8 years ago
Hm.  Thought I tried that.  But in any case, can't check right now, all my windows machines are at work.

If anyone over there has a windows box to test on...  Otherwise, Monday. :)
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 595842
blocking2.0: ? → ---
You need to log in before you can comment on or make changes to this bug.