Last Comment Bug 596295 - Removing call_trace workaround (added for bug 592352) leaks
: Removing call_trace workaround (added for bug 592352) leaks
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: Trunk
: All All
-- normal (vote)
: mozilla9
Assigned To: Peter Van der Beken [:peterv]
:
: Jason Orendorff [:jorendorff]
Mentors:
Depends on: 592352
Blocks:
  Show dependency treegraph
 
Reported: 2010-09-14 11:00 PDT by Ben Turner (not reading bugmail, use the needinfo flag!)
Modified: 2011-09-01 01:38 PDT (History)
17 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
-
wanted


Attachments
v1 (1.43 KB, patch)
2011-08-29 07:24 PDT, Peter Van der Beken [:peterv]
luke: review+
Details | Diff | Splinter Review

Description User image Ben Turner (not reading bugmail, use the needinfo flag!) 2010-09-14 11:00:57 PDT
Bug 592352 was noticed when removing a call_trace hack in jsfun.cpp. Now that IndexedDB has been fixed other things are leaking, see bug 592352 comment 22. This bug will be about fixing the remaining leak and hopefully removing the workaround.
Comment 1 User image David Mandelin [:dmandelin] 2010-12-09 17:11:33 PST
I'm not sure what this bug is, but it looks like it's about removing a workaround. It doesn't sound critical for release. Correct me if I'm wrong.
Comment 2 User image Johnny Stenback (:jst, jst@mozilla.com) 2010-12-09 17:17:06 PST
Ben, please clarify what this is about. Do we have a leak right now, or do we get a leak if we remove the workaround? Assuming we don't leak right now I'm marking this blocking-, but please renominate if this is a current leak.
Comment 3 User image Luke Wagner [:luke] 2011-08-03 15:31:25 PDT
Peter: do you think any of your cycle collector work will obviate the call_trace hack?  We were just running into and scratching our heads with incremental GC work.
Comment 4 User image Peter Van der Beken [:peterv] 2011-08-04 07:15:04 PDT
Yes, I'm pretty sure I can land this soon together with the ClearScope removal.
Comment 5 User image Luke Wagner [:luke] 2011-08-04 09:12:03 PDT
\o/
Comment 6 User image Peter Van der Beken [:peterv] 2011-08-29 07:24:12 PDT
Created attachment 556544 [details] [diff] [review]
v1
Comment 7 User image Luke Wagner [:luke] 2011-08-29 08:27:35 PDT
Comment on attachment 556544 [details] [diff] [review]
v1

Review of attachment 556544 [details] [diff] [review]:
-----------------------------------------------------------------

r++
Comment 8 User image Ed Morley [:emorley] 2011-09-01 01:38:38 PDT
http://hg.mozilla.org/mozilla-central/rev/7670696cd700

Note You need to log in before you can comment on or make changes to this bug.