Last Comment Bug 596388 - No Firefox builds on http://tinderbox.mozilla.org/showbuilds.cgi?tree=Mozilla-l10n-af&hours=72 etc for 3 days
: No Firefox builds on http://tinderbox.mozilla.org/showbuilds.cgi?tree=Mozilla...
Status: RESOLVED FIXED
:
Product: Release Engineering
Classification: Other
Component: Other (show other bugs)
: other
: All All
: P2 normal (vote)
: ---
Assigned To: Chris AtLee [:catlee]
:
Mentors:
http://tinderbox.mozilla.org/showbuil...
Depends on:
Blocks: releng-downtime
  Show dependency treegraph
 
Reported: 2010-09-14 14:53 PDT by Axel Hecht [:Pike]
Modified: 2013-08-12 21:54 PDT (History)
3 users (show)
bhearsum: needs‑treeclosure+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
Re-import upstream's tinderbox.py (4.34 KB, patch)
2010-09-15 14:32 PDT, Chris AtLee [:catlee]
nthomas: review+
bhearsum: checked‑in+
Details | Diff | Splinter Review

Description Axel Hecht [:Pike] 2010-09-14 14:53:18 PDT
There are no Firefox builds reported to the per-locale tinderbox pages. http://tinderbox.mozilla.org/showbuilds.cgi?tree=Mozilla-l10n-af&hours=72 is not showing any, while http://tinderbox.mozilla.org/showbuilds.cgi?tree=Mozilla-l10n&hours=72 does, same for de, at least.

This blocks me from checking that we actually have successful builds for new locales on Firefox 4 Beta 7.
Comment 1 Armen Zambrano [:armenzg] - Engineering productivity 2010-09-15 10:07:55 PDT
Looking at the admin pages for a couple of individual locales I don't think we are reporting any Firefox l10n build unto those pages.

We seem to still have that code in place for buildbot-0.8.0:
http://hg.mozilla.org/build/buildbotcustom/file/buildbot-0.8.0/misc.py#l666
and the only difference that I see with the default branch:
http://hg.mozilla.org/build/buildbotcustom/file/default/misc.py#l1189
is the from address.

The other differences I see are:
* if config['enable_l10n_onchange']:
* nomergeBuilders.extend(l10n_builders)

I see the code enabling the l10n on change:
* mozilla/config.py:BRANCHES['mozilla-central']['enable_l10n_onchange'] = True

I ain't got time as of now but I thought this info could help. I don't see at first anything that got lost when porting to 0.8.0 masters.
Comment 2 Axel Hecht [:Pike] 2010-09-15 10:15:28 PDT
I think this worked in post 0.8.0 era times, too. Seems like a really recent regression.

Regression range is between http://tinderbox.mozilla.org/showbuilds.cgi?tree=Mozilla-l10n-af&maxdate=1283015590&hours=72&legend=0&norules=1 and http://tinderbox.mozilla.org/showbuilds.cgi?tree=Mozilla-l10n-af&maxdate=1283274790&hours=72&legend=0&norules=1, likely post 2010/08/28.
Comment 3 Armen Zambrano [:armenzg] - Engineering productivity 2010-09-15 10:33:21 PDT
Maybe?
* Bug 589765: Set treeStableTimer=None for l10n repack jobs. - http://hg.mozilla.org/build/buildbotcustom/rev/30499aa7f126
* Bug 559150: Don't use hard coded values for pollInterval and l10nPollInterval. - http://hg.mozilla.org/build/buildbotcustom/rev/770d99c11673

From looking at commit messages on the 0.8.0 branch.
I so wish we had a unit test for this and when the repacks don't trigger on-change as it takes long to notice.
Comment 4 Axel Hecht [:Pike] 2010-09-15 10:59:21 PDT
So the problem is that TinderboxMailNotifier doesn't support WithProperties for tree. No wonder if or why that regressed.
Comment 5 Chris AtLee [:catlee] 2010-09-15 11:09:02 PDT
Most likely got lost in the 0.8.1 upgrade.
Comment 6 Chris AtLee [:catlee] 2010-09-15 14:32:41 PDT
Created attachment 475639 [details] [diff] [review]
Re-import upstream's tinderbox.py
Comment 7 Ben Hearsum (:bhearsum) 2010-10-01 09:42:02 PDT
Landing on Monday.
Comment 8 Ben Hearsum (:bhearsum) 2010-10-04 07:42:03 PDT
These appear to be working again.
Comment 9 Ben Hearsum (:bhearsum) 2010-10-04 07:47:54 PDT
Comment on attachment 475639 [details] [diff] [review]
Re-import upstream's tinderbox.py

Landed in 69c9e45f48e3

Note You need to log in before you can comment on or make changes to this bug.