too aggressive search for XPCOM functions

RESOLVED FIXED in 1.0

Status

P1
normal
RESOLVED FIXED
8 years ago
8 years ago

People

(Reporter: mcepl, Assigned: warner)

Tracking

unspecified

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
On start of cfx run I get this:

To use chrome authority, as in:
 /home/matej/archiv/2010/projekty/bugzilla-triage/lib/rhbzpage.js
 52> soughtLines: new RegExp("^\\s*(\\[[0-9 .]*\\])?\\s*\\(\\((EE|WW)\\)|.* [Cc]hipsets?: \\)|\\s*Backtrace")
You must enable it with something like:
  const {Cc} = require("chrome");

The particular line in the code is:

        soughtLines: new RegExp("^\\s*(\\[[0-9 .]*\\])?\\s*\\(\\((EE|WW)\\)|.* [cC]hipsets?: \\)|\\s*Backtrace")

I mean, really?
The Add-on SDK is no longer a Mozilla Labs experiment and has become a big enough project to warrant its own Bugzilla product, so the "Add-on SDK" product has been created for it, and I am moving its bugs to that product.

To filter bugmail related to this change, filter on the word "looptid".
Component: Jetpack SDK → General
Product: Mozilla Labs → Add-on SDK
QA Contact: jetpack-sdk → general
Assignee: nobody → warner-bugzilla
OS: Linux → All
Priority: -- → P1
Hardware: x86_64 → All
Target Milestone: --- → 1.0
(Assignee)

Comment 2

8 years ago
See also bug 655788 : I think the scanner should ignore Cc/Cr/Cu/etc, and only look for "Components." . That means it won't be able to suggest a precise require("chrome") line (since it won't try to figure out which exact pieces they're using), but I think that's reasonable.
(Assignee)

Updated

8 years ago
Duplicate of this bug: 655788
(Assignee)

Comment 4

8 years ago
Created attachment 533091 [details] [diff] [review]
make the chrome/XPCOM scanner less clever, reduce false positives

this ought to reduce the number of false positives. Also visible in https://github.com/mozilla/addon-sdk/pull/168
Attachment #533091 - Flags: review?(rFobic)
Comment on attachment 533091 [details] [diff] [review]
make the chrome/XPCOM scanner less clever, reduce false positives

Review of attachment 533091 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good!
Attachment #533091 - Flags: review?(rFobic) → review+

Comment 6

8 years ago
Comment on attachment 533091 [details] [diff] [review]
make the chrome/XPCOM scanner less clever, reduce false positives

Review of attachment 533091 [details] [diff] [review]:
-----------------------------------------------------------------

https://wiki.mozilla.org/User:Gilma.gamez
(Assignee)

Comment 7

8 years ago
Landed, in https://github.com/mozilla/addon-sdk/commit/ea11d7857311dce5be7632240df1522b9d3788f0
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.