Closed
Bug 59682
Opened 25 years ago
Closed 24 years ago
IMAP: Should display correct warning Alert and specify server name when IMAP server is down or network disconnecting problem
Categories
(MailNews Core :: Networking: IMAP, defect, P1)
Tracking
(Not tracked)
VERIFIED
FIXED
mozilla0.9.9
People
(Reporter: huang, Assigned: cavin)
References
(Depends on 1 open bug)
Details
Used 11-08-01-MN6 build
Overview:
Refer to bug 58547, we should display a correct warning Alert when IMAP server
is down or network disconnecting problem.
Setup Info:
1) Setup SERA Internet/Intranet Access
2) Disconnect SERA Internet/Intrant Access
Steps:
1) Login to above setup IMAP mail account.
2) Read and view existing mail messages.
3) Break current network connection (such as by disconnecting from SERA)
4) Actual Results: Will display an general alert: "Connection refused to the
server".
Expected results:
netscape 6 should display correct warning Alert(as 4.x) to warn users that there
is server down problem or network problem, so users can try connecting again.
Additional Info: The warning alert displaying from the 4.x is as following:
"The server has disconnected. The server may have gone down or there may be a
network problem. Try connecting again.."
Hope the correct warning Alert will display on Netscape 6.5.
| Reporter | ||
Updated•25 years ago
|
QA Contact: esther → huang
| Reporter | ||
Comment 1•25 years ago
|
||
I believe that this bug should apply to other IMAP servers as well (Webamil, AOL
...etc.)since currently we all get the general alert: "Connection refused to the
server" when AOL/Webamil servers are down.......
Comment 2•25 years ago
|
||
There is a difference between connection refused and the server being down.
We're trying to be more specific, so we don't want to put up the general alert.
In this particular case, it's not a network problem - the host machine is up and
running, but not accepting connections. Perhaps some more explanatory text would
be better, but the error msg is basically correct, and the 4.x one you're
suggesting would be incorrect.
cc'ing Robin for wording suggestion.
Sounds like we need two different text strings then? Is that correct?
1. Connection refused by the Server.
2. The server is down.
| Reporter | ||
Comment 5•24 years ago
|
||
According to PRD, this should be nominated nsbeta1 for better error handling.
Keywords: nsbeta1
Comment 6•24 years ago
|
||
Although Bug 95302 has been closed as a dup of this bug, this bug says nothing
about the fact that the error message does not refer to the server which
caused the error, which was the point of bug 95302. Please advise whether
95302 should be reopened, or if this bug is being generally used to track
improving the friendliness of network alerts.
Please stop using "the server" and indicate the name of the server the error
is referring to at least one in the error dialog.
Comment 7•24 years ago
|
||
Ah, ok... untangling the web of bugs led me to bug 66860 which does talk about
including the server name, this bug is languishing because it's also
suggesting changing the status bar.
There's a much stronger case for fixing the alerts, because they are really
useless if you have multiple accounts. In addition, it's less contraversial
than changing the status bar, the benefits of which are negligable. Could the
lack of server name be fixed as part of this bug (see Tuukka Tolvanen's
comments at the end of bug 66860)?
| Reporter | ||
Comment 8•24 years ago
|
||
Good suggestion! I added "specify server name" on this bug summary too.
Hope this bug can fix the server name as well, if developers think that should
be treated as different bugs, at least we have bug 66860 for tracking the
server name too. Thanks for bring this up!
Summary: IMAP: Should display correct warning Alert when IMAP server is down or network disconnecting problem → IMAP: Should display correct warning Alert and specify server name when IMAP server is down or network disconnecting problem
Comment 9•24 years ago
|
||
nsbeta1+ for seeing if we can get the server name in there for being able to
distinguish between multiple accounts we might be trying to open.
Comment 10•24 years ago
|
||
Suggested wording for "Connection refused": "Your network connection to the
server <server name> has been lost. Check your network connection and try
connecting again."
Suggested wording for "server is down": "The server <server name> has
disconnected. The server may be unavailable or there may be a network problem.
Try connecting again."
Comment 11•24 years ago
|
||
reassigning to cavin.
Assignee: mscott → cavin
Target Milestone: --- → mozilla0.9.9
| Reporter | ||
Comment 12•24 years ago
|
||
>I believe that this bug should apply to other IMAP servers as well (Webamil,
AOL ...etc.)since currently we all get the general alert: "Connection refused to
>the server" when AOL/Webamil servers are down.......
Cavin, should this fix POP as well?
| Assignee | ||
Comment 13•24 years ago
|
||
Yes.
| Assignee | ||
Comment 14•24 years ago
|
||
Marking fixed because bug 100167 has been fixed. In addition, we do have
different error messages for different 'connection failures':
1. Failed to connect to server %S.
2. Could not connect to server %S; the connection was refused.
3. Connection to server %S timed out.
Please reopen it if you don't agree.
Status: NEW → RESOLVED
Closed: 24 years ago
Resolution: --- → FIXED
| Reporter | ||
Comment 15•24 years ago
|
||
Verified on Windows 05-20-08-1.0.0 build
Now, our client is displaying "Could not connect to mail server parp.mcom.com;
the connection was refused" instead of "Connection refused to the
server" general alert.
Marking as verified.
Status: RESOLVED → VERIFIED
Updated•21 years ago
|
Product: MailNews → Core
Updated•17 years ago
|
Product: Core → MailNews Core
You need to log in
before you can comment on or make changes to this bug.
Description
•