Closed Bug 596839 Opened 10 years ago Closed 4 years ago

Add Bittorrent support for automatic application updates

Categories

(Toolkit :: Application Update, enhancement)

enhancement
Not set

Tracking

()

RESOLVED WONTFIX

People

(Reporter: christian, Unassigned)

References

Details

It would be nice to be able to deliver Firefox automatic updates via Bittorrent. We currently rely heavily on mirrors and prefer not to pay a cdn. The mirrors may go away one day and/or may impact a timely release down the road if we cannot get sufficient uptake.

It'd be nice to implement Bittorrent (or something similar) to spread the load out on all Firefox users. This helps:

* MoCo as we can do more updates with less cost and risk. This will be more important as we move to faster releases and more project branches
* Mirror sites as they will need to provide less bandwidth
* Users, as their updates will likely download quicker (especially in the University/LAN case)

In the worst case (blocking bitorrent ports, throttling, etc) we could fall back to the current behavior.

To be clear, this is *not* a dupe of bug 236755. That bug wants us to support Bittorrent generally in Firefox. This is just for the software update case.
Depends on: BitTorrent
Please file a core -> networking bug to add bitorrent support for downloading so app update could then use bitorrent to download. :)
should have reaalized there would already be one. :)
(In reply to comment #0)
> It would be nice to be able to deliver Firefox automatic updates via
> Bittorrent. We currently rely heavily on mirrors and prefer not to pay a cdn.
> The mirrors may go away one day and/or may impact a timely release down the
> road if we cannot get sufficient uptake.

That's actually happened in the past and we did just fine by acting as origin for downloads ourselves.

Today if that happened, we'd do the same + augment with CDN.  We -prefer- not to pay, but we -prefer- to get releases in the absence of mirror capacity.
Update since 2010: We are on CDN for updating now. It hurts financially, but we make up for it with improved download->install conversion rates. In the end, it was decided the change was worthwhile. It would be great to have our cake and eat it too. :)

I don't know how much effort would be required to implement this, but it has the potential to save Mozilla a lot of money. The CDN would still operate as a fallback, but a native BT mechanism could potentially handle a large percentage of the traffic.
(In reply to Jake Maul [:jakem] from comment #4)
> Update since 2010: We are on CDN for updating now. It hurts financially, but
> we make up for it with improved download->install conversion rates. In the
> end, it was decided the change was worthwhile. It would be great to have our
> cake and eat it too. :)
> 
> I don't know how much effort would be required to implement this, but it has
> the potential to save Mozilla a lot of money. The CDN would still operate as
> a fallback, but a native BT mechanism could potentially handle a large
> percentage of the traffic.
Bug 236755 would first need to be implemented.
Could do this in the stub installer too?
Not without increasing the size of the stub installer... likely by quite a lot.
Without bug 236755 this is wontfix
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.