Closed Bug 596889 Opened 10 years ago Closed 10 years ago

Selection of images in nsHTMLEditor turn them 100% white

Categories

(Core :: DOM: Selection, defect)

x86
All
defect
Not set
major

Tracking

()

RESOLVED DUPLICATE of bug 599368
mozilla2.0

People

(Reporter: glazou, Assigned: dbaron)

References

Details

(Keywords: regression)

tested with build 4.0b7pre Snow Leopard 15-sep-2010.
steps to reproduce:

1. open the Midas demo at http://www.mozilla.org/editor/midasdemo/

2. type some chars in the editable area

3. insert an image, for instance http://www.mozilla.org/images/home/projects/firefox.png using the 2nd toolbarbutton from the right of first toolbar

4. click on the image you just inserted to select it

Expected result: image selected and visible
Actual result: image selected and invisible, the box is white

This bug hits _all_ instances of the editor, including BlueGriffon, and of course all instances of contenteditable or online web editors like blog systems.
asking for blocking2.0 status
blocking2.0: --- → ?
Just tested with FF 4b6 on Mac 10.5 and the selected image does not turn white. Is this a recent regression?
If I do the STRs in a current SeaMonkey debug build I get lots of those warnings:

WARNING: Someone passed native anonymous content directly into frame construction.  Stop doing that!: file /home/i6stud/sibresch/nobackup/seamonkey_hg/trees/comm-central/mozilla/layout/base/nsCSSFrameConstructor.cpp, line 6006

WARNING: Nonempty list left over?: file /home/i6stud/sibresch/nobackup/seamonkey_hg/trees/comm-central/mozilla/layout/base/nsDisplayList.h, line 715
Confirmed on Linux x86_64 as well.

Works in: Mozilla/5.0 (X11; Linux x86_64; rv:2.0b6pre) Gecko/20100909 Firefox/4.0b6pre (buildID = 20100909030732)

Broken in: Mozilla/5.0 (X11; Linux x86_64; rv:2.0b6pre) Gecko/20100910 Firefox/4.0b6pre (buildID = 20100910030851)

The two closest archived nightly builds I could find for my platform.
OS: Mac OS X → All
Using about:buildconfig in the nightlies gives this regression range.

http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=8e0fce7d5b49&tochange=79d0beec27b5
I'm bisecting the range...
Landing of changeset 0aa1272e932f of Bug 485501 causes the problem.
(In reply to comment #8)
> Landing of changeset 0aa1272e932f of Bug 485501 causes the problem.

Heh, I just finished bisecting and saw your comment!  And that's totally true.

Tentatively assigning to dbaron.
Assignee: nobody → dbaron
Blocks: 485501
Bug 599368 should technically be marked as a dupe of this one, but since that bug is marked as a blocker, I'm marking this as a dupe of bug 599368.
Status: NEW → RESOLVED
blocking2.0: ? → ---
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 599368
You need to log in before you can comment on or make changes to this bug.