Closed Bug 597010 Opened 9 years ago Closed 9 years ago

Some form elements are rendered with thick black borders on Maemo/GTK

Categories

(Firefox for Android Graveyard :: General, defect)

ARM
Maemo
defect
Not set

Tracking

(fennec2.0b1+)

VERIFIED FIXED
Tracking Status
fennec 2.0b1+ ---

People

(Reporter: aakashd, Assigned: mfinkle)

Details

Attachments

(3 files, 2 obsolete files)

Build Id:
Mozilla/5.0 (Maemo; Linux armv71; rv:2.0b6pre) Gecko/20100916 Namoroka/4.0b7pre Fennec/2.0b1pre

Steps to Reproduce:
1. Go to bugzilla.mozilla.org/

Actual Results:
The buttons and input fields on the page will be bordered black

Expected Results:
The borders of the buttons and input fields should not be black and colored however way fennec wants it to be colored.
tracking-fennec: --- → ?
Attached image screenshot
Screenshot shows the boxes in the middle with the issue
Summary: Native theme seeps into webpage widgets → Some form elements are rendered with thick black borders
Including in notes from what the screenshot was from :  

Mozilla/5.0 (Maemo;Linux armv71; rv:2.0b7pre)Gecko/20100916 Firefox/4.0b7pre Fennec/2.0b1pre
Summary: Some form elements are rendered with thick black borders → Some form elements are rendered with thick black borders on Maemo/GTK
Simple form testing with textboxes, radio buttons, checkboxes, drop down boxes show this issue:
1. goto http://people.mozilla.com/~nhirata/html_tp/formsninput.html
Assignee: nobody → doug.turner
tracking-fennec: ? → 2.0b2+
You can also just try https://mail.mozilla.com.  attached another screen.
Attached patch Simple band-aid patch (obsolete) — Splinter Review
This patch simply turns off all native theming for all widgets. It "fixes" the problem, but I'd like to know why this regressed.

Fennec uses a preference to disable native theme support. The colors and borders you see in this bug are due to native theme setting the defaults. As I mentioned, Fennec should be turning off native theme.

I only see this error in remote pages and the regression seemed to after after cedar landed on m-c. I have been looking into how puppet widgets interact with the native theme system, but I haven't found any clue of native theme in puppet widgets. I guess that might be the problem. Puppet widgets probably need to be taught about native themes and how to disable them?
Assignee: doug.turner → mark.finkle
Too see this bug on desktop Lnux, just change the desktop appearance to an inverse theme. While your desktop will look like crap, you should not see any difference in Fennec.
Attached patch css changes only (obsolete) — Splinter Review
The last patch had other stuff in it. This patch is all that is needed.
Attachment #477031 - Attachment is obsolete: true
Attached patch stricter css fixSplinter Review
This patch uses an existing rule and should be better for performance.
Attachment #477034 - Attachment is obsolete: true
Attachment #477108 - Flags: review?(21)
Comment on attachment 477108 [details] [diff] [review]
stricter css fix

Could you put a comment when landing to remind us to remove it once the cedar regression will be fixed?
Attachment #477108 - Flags: review?(21) → review+
pushed:
http://hg.mozilla.org/mobile-browser/rev/c76cedf4ca18

filed bug 598421 for the platform fix
Status: NEW → RESOLVED
tracking-fennec: 2.0b2+ → 2.0b1+
Closed: 9 years ago
Resolution: --- → FIXED
verified FIXED on build:
Mozilla/5.0 (Maemo; Linux armv71; rv:2.0b6pre) Gecko/20100922 Namoroka/4.0b7pre Fennec/2.0b1pre
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.