Table row height is broken

RESOLVED DUPLICATE of bug 58402

Status

()

Core
Layout: Tables
P3
normal
RESOLVED DUPLICATE of bug 58402
17 years ago
17 years ago

People

(Reporter: Marcelo Vanzin, Assigned: karnaze (gone))

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
If you have a cell that spans to multiple rows, and try to declare row heights
for different rows, Mozilla brakes the layout in most of the situations. I've
created a few pages to illustrate that.

(i) Transitional rendering in "quirks mode"
http://www.geocities.com/mvanzin/mozilla/quirks_1.html
This should be the correct behaviour for all cases. The spanned row has height
of 68, and the first row has a 28 height. In all cases, the height for the
second row should be 40, even when not declared (this row has only empty cells).

(ii) Transitional rendering in "quirks mode" - part 2
http://www.geocities.com/mvanzin/mozilla/quirks_2.html
Here I ommit the row height for the second row, and in this case Mozilla ignores
the row height setting for the first row, breaking the layout.

(iii) Transitional rendering in "standards mode"
http://www.geocities.com/mvanzin/mozilla/stds_1.html
Same as case (i) above, but rendering in standards mode (4.01 Transitional).
Layout is broken (row height for the first row is wrong).

(iv) Transitional rendering in "standards mode" - part 2
http://www.geocities.com/mvanzin/mozilla/stds_2.html
Same as case (ii) above.

Deleting the spanned row (with the logo image) fixes case (ii) and makes case
(iv) looks just like case (iii) (being both standards mode rendering wrong).

Comment 1

17 years ago
Related to bug 58402?
(Reporter)

Comment 2

17 years ago
Hmm, yes, it seems. Maybe marking as duplicate?

Anyway, the test cases I created show problems in quirks mode also, which are
not listed on bug 58402.

I'm marking as duplicated and will post my comments there.

*** This bug has been marked as a duplicate of 58402 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 3

17 years ago
QA contact update
QA Contact: chrisd → amar
You need to log in before you can comment on or make changes to this bug.