Closed Bug 597186 Opened 9 years ago Closed 9 years ago

Letters in The Wilderness Downtown demo drawn incorrectly

Categories

(Core :: Canvas: 2D, defect)

defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 595963

People

(Reporter: cade, Unassigned)

References

()

Details

(Whiteboard: [chromeexperiments])

Attachments

(2 files)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.8) Gecko/20100722 Firefox/3.6.8
Build Identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b7pre) Gecko/20100914 Firefox/4.0b7pre 

In the Wilderness Downtown Experiment, There is a segment where you send a "postcard" In chrome, when you type the letters appear on the screen, stylized (screen shot here: http://www.flickr.com/photos/cadecairos/4997023386 ).  In Firefox however, the letter are not painted properly (seen here: http://www.flickr.com/photos/cadecairos/4996818030 ).  In both cases I typed the letters A-Z in alphabetical order on the top of the screen. 

It's probably unrelated, but if you look at the doodling in each case you'll see Firefox also has some trouble there as well. (separate bug?)

Reproducible: Always
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Letters drawn incorrectly on canvas in Firefox → Letters in The Wilderness Downtown demo drawn incorrectly
Whiteboard: [chromeexperiments]
Version: unspecified → Trunk
So what are the steps to reproduce?  Just load the thing and wait for the postcard stuff to appear?

Is this a regression?
From the screenshots it looks like a disagreement about when new paths are supposed to begin, and/or behavior of lineTo and friends without an initial point in a new path.  But that's just a guess; would need a testcase to play with/examine.
(In reply to comment #1)
> So what are the steps to reproduce?  Just load the thing and wait for the
> postcard stuff to appear?
 
yes it happens during the demo, and afterwards too, when you can edit the postcard without interruption. 

I tried making a locally playable version of the postcard editor but wasn't very successful. I'm still hacking at it though.
Attached file Test case for letter A
I reduced this to the point that I can just draw the letter A--it's still a lot of code the way they do it.  I see two different issues in 3.6 vs. trunk.  In 3.6 I get the basic shape of the A, but no branching.  On trunk, I get the following error:

Error: this.branches[i] is undefined
Source File: file:///Users/dave/tmp/wilderness/index.html
Line: 667

I wonder if the latter is bug 595963?  Chrome doesn't lose array elements.
I think it's the opposite. Firefox is render things correctly while Chrome/Windows/Linux is not. Unfortunately most of the people that worked on that part were using MacOS and never realised.

To sum it up, Chrome/MacOS (CoreGraphics) and Firefox seem to be rendering that fine. I think it's a problem of Skia drawing lines with very low opacity values.
I'll double check with the director though.
I don't think that's what I'm seeing.  Firefox doesn't draw branches at all for me, and I'm on Mac, the possible js bug notwithstanding.
Here's what I see on Mac, 10.6, with Firefox 3.6, Minefield nightly, Chrome, Safari.
Does that happen only with the letters? Or also when drawing using the mouse?
Standalone version of the drawing tool:
http://thewildernessdowntown.com/view.html
That works for me, both on trunk and 3.6.
Yeah, this is bug 595963. Thanks for helping narrow it down.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 595963
This bug was marked as a duplicate of https://bugzilla.mozilla.org/show_bug.cgi?id=595963 , which has since been marked as resolved, but I still see the letters being drawn incorrectly on Firefox 4. Is anyone else seeing this as well?
With regards to last comment.  Looked up this bug 'cause I was hoping it had been fixed.
And happy to say it does indeed work fine.

Firefox 8.0a1 nightly 2011-07-06 (Linux x86_64)

Try using a more recent version?
You need to log in before you can comment on or make changes to this bug.