If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Submenus next to menu items are very confusing in the Firefox menu

RESOLVED WONTFIX

Status

()

Firefox
General
RESOLVED WONTFIX
7 years ago
7 years ago

People

(Reporter: hsivonen, Unassigned)

Tracking

Trunk
All
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
Steps to reproduce:
 1) Use Windows 7
 2) Get a Minefield build from around 2010-09-17
 3) Assuming the menu bar is visible, choose View: Toolbar: Menu bar to hide the menubar and to show the Firefox menu.
 4) Click the Firefox menu to open it.
 5) Click the label "Developer".
 6) Now click the label "Options..."

Actual results:
Clicking "Developer" opens a submenu. Clicking "Options..." opens the pref window even though there's a submenu indicator arrow next to the label. (If you pay attention while moving the mouse to click, the hover effect reveals that "Developer" and the other items that look like submenu labels are actually different kinds of items.)

Expected results:
Expected clicking a menu item whose label has an arrow next to it to open a submenu always.

Comment 1

7 years ago
Maybe we should do what they do in Office 2007 right click menus, where they have a vertical grey line between the split menu items.
This behaves as intended, except for bug 589146.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WONTFIX

Updated

7 years ago
Duplicate of this bug: 617483
You need to log in before you can comment on or make changes to this bug.