Last Comment Bug 597389 - If plug-ins disable non-Roman keyboard layout and they don't recover the state, Gecko doesn't recover it
: If plug-ins disable non-Roman keyboard layout and they don't recover the stat...
Status: RESOLVED FIXED
: flashplayer, inputmethod, intl, jp-critical, verified1.9.1, verified1.9.2
Product: Core
Classification: Components
Component: Widget: Cocoa (show other bugs)
: 1.9.2 Branch
: x86 Mac OS X
: P1 major (vote)
: ---
Assigned To: Masayuki Nakano [:masayuki] (Mozilla Japan)
:
Mentors:
http://www.tbs.co.jp/radio/todays954/
Depends on: 601440
Blocks:
  Show dependency treegraph
 
Reported: 2010-09-17 06:23 PDT by Masayuki Nakano [:masayuki] (Mozilla Japan)
Modified: 2010-10-11 12:38 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
unaffected
needed
.11-fixed
needed
.14-fixed


Attachments
Patch v1.0 (1.58 KB, patch)
2010-09-17 06:23 PDT, Masayuki Nakano [:masayuki] (Mozilla Japan)
smichaud: review+
dveditz: approval1.9.2.11+
dveditz: approval1.9.1.14+
Details | Diff | Review

Description Masayuki Nakano [:masayuki] (Mozilla Japan) 2010-09-17 06:23:53 PDT
Created attachment 476234 [details] [diff] [review]
Patch v1.0

1. Load above page with Fx3.6 and Flash Player 10.1.x.x
2. Click a link in the Flash Player which is center of the page (the radio program list)

Then, you cannot use non-Roman keyboard layout on Fx.

Flash Player disables non-Roman keyboard layout and if you click the link, Flash Player doesn't recover the keyboard layout state when it's destroying. Gecko stores latest keyboard layout state when Gecko changes it because 10.4 doesn't provide any APIs for getting the state. And Gecko reduces unnecessary API call at nsTSMManager::SetRomanKeyboardsOnly(). Therefore, Gecko doesn't restore the keyboard state until Gecko's password field gets focus.

# NOTE #1: This bug isn't reproduced on Minefield, probably, the reason is that Minefield uses new APIs which are usable 10.5 and later.
# NOTE #2: This bug isn't reproduced with Flash Player 10.0.x.x. So, this is a regression of Flash Player.
Comment 1 Masayuki Nakano [:masayuki] (Mozilla Japan) 2010-09-17 06:48:00 PDT
This bug can be reproduced on Fx3.5 too. However, it's going to be dropped but SeaMonkey is going to continue to use 1.9.1 for a while. So, we should fix this bug on 1.9.1 too.
Comment 2 Steven Michaud [:smichaud] (Retired) 2010-09-17 09:55:41 PDT
I can't reproduce this bug (testing in FF 3.6.9 on OS X 10.5.8) ... or
at least I don't think I can.

Here's what I did:

1) Load this bug's URL (http://www.tbs.co.jp/radio/todays954/) and
   click somewhere in the Flash object.

   Notice that it's no longer possible to choose Kotoeri Hiragana or
   Katakana from the "flags" menu (those choices are greyed out).

2) Click elsewhere in the page.

   Now it's once again possible to choose Hiragana or Katakana.

3) Click on the Flash object -- Hiragana and Katakana are greyed out.

4) Switch tabs -- Hiragana and Katakana are no longer greyed out.

5) Switch back to the tab with http://www.tbs.co.jp/radio/todays954/
   in it -- Hiragana and Katakana are still not	greyed out.

6) Click on the Flash object -- Hiragana and Katakana are greyed out.

7) Close the current tab (with http://www.tbs.co.jp/radio/todays954/
   in it) -- Hiragana and Katakana are no longer greyed out.

Later I'll try it on OS X 10.6.4.
Comment 3 Steven Michaud [:smichaud] (Retired) 2010-09-17 10:04:52 PDT
(Following up comment #3)

I get the same results on OS X 10.6.4.

By the way, on both OS versions I tested with en-US Firefox and the preferred language was set to English.
Comment 4 Masayuki Nakano [:masayuki] (Mozilla Japan) 2010-09-17 11:11:37 PDT
Click a link in the Flash Object. Then, you'll open a page on current tab. Then, the keyboard layout limitation isn't canceled.

I can reproduced this bug on 10.5 and 10.6. The original reporter in Japan said that he/she can reproduce this bug on 10.4 too.
Comment 5 Daniel Veditz [:dveditz] 2010-09-17 11:26:08 PDT
CC'ing Charles because it appears it might also be a Flash regression
Comment 6 Steven Michaud [:smichaud] (Retired) 2010-09-17 11:49:17 PDT
> Click a link in the Flash Object. Then, you'll open a page on
> current tab.  Then, the keyboard layout limitation isn't canceled.

OK, thanks.  Now I can reproduce it.
Comment 7 Steven Michaud [:smichaud] (Retired) 2010-09-17 11:52:07 PDT
Comment on attachment 476234 [details] [diff] [review]
Patch v1.0

This looks fine to me.
Comment 8 Masayuki Nakano [:masayuki] (Mozilla Japan) 2010-09-17 12:04:21 PDT
Comment on attachment 476234 [details] [diff] [review]
Patch v1.0

Thank you, Steven.

This patch just removes an optimizing code for reducing API call. I think that this change doesn't affect to performance.
Comment 9 Masayuki Nakano [:masayuki] (Mozilla Japan) 2010-09-17 12:07:14 PDT
NOTE: the method is called at focus moving only when IME state is changed by new focused content.
Comment 10 Daniel Veditz [:dveditz] 2010-09-20 10:34:44 PDT
Comment on attachment 476234 [details] [diff] [review]
Patch v1.0

Approved for 1.9.2.11 and 1.9.1.14, a=dveditz for release-drivers
Comment 12 [On PTO until 6/29] 2010-09-23 16:43:50 PDT
Verified fixed in 1.9.2 with Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.2.11pre) Gecko/20100923 Namoroka/3.6.11pre. Verified fixed in 1.9.1 with Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.1.14pre) Gecko/20100923 Shiretoko/3.5.14pre.

Note You need to log in before you can comment on or make changes to this bug.