Note: There are a few cases of duplicates in user autocompletion which are being worked on.

Support building of app components into libxul

RESOLVED FIXED in mozilla2.0b7

Status

()

Core
Build Config
RESOLVED FIXED
7 years ago
7 years ago

People

(Reporter: standard8, Assigned: standard8)

Tracking

Trunk
mozilla2.0b7
Points:
---
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(blocking2.0 final+)

Details

Attachments

(1 attachment)

Created attachment 476306 [details] [diff] [review]
The fix

As part of the work we're doing to make SeaMonkey and Thunderbird build with libxul, we'd like to be able to link the application components into libxul.

This patch was originally suggested by Ted for Firefox, but not used. I've extended it and fixed it up so that SeaMonkey and Thunderbird can use it.

I think I would investigate support for static libxul in the future (and then maybe drop this way), but the quicker and much needed fix is to do it this way around - we can then more easily break static builds, and re-invent them to give us static libxul.

I'm pretty confident this patch is going to work for us now - we've just got things in comm-central to resolve.
Attachment #476306 - Flags: review?(khuey)
Comment on attachment 476306 [details] [diff] [review]
The fix

bsmedberg already reviewed this in the other bug, and it doesn't look like it's changed substantively, so r+.
Attachment #476306 - Flags: review?(khuey) → review+
Comment on attachment 476306 [details] [diff] [review]
The fix

Requesting approval for landing on 2.0 - this adds some build config options which will mean that Thunderbird and SeaMonkey will be able to build and ship libxul-style.

This will clear some of the blockers to letting the build system to move forward for all apps,
Attachment #476306 - Flags: approval2.0?

Comment 3

7 years ago
As it's unclear if non-blockers can land at this point on m-c but this blocks all Windows builds of Thunderbird and SeaMonkey on trunk, I'm nominating this as blocking.
blocking2.0: --- → ?
(In reply to comment #3)
> As it's unclear if non-blockers can land at this point on m-c but this blocks
> all Windows builds of Thunderbird and SeaMonkey on trunk, I'm nominating this
> as blocking.

Yes, we really do need this ASAP - I've been holding the tree closed because we have no Windows nightly builds, which were caused by a different issue, but it would be a really bad hack to get around that issue, and this way gets us to the same ending and better. I'd really rather not want to wait multiple days for the last blockers and a potential branch to happen.

It could almost be considered NPOTB except that I guess that it touches the same build-config files that Firefox uses, which would be stretching the typical definition a lot.
blocking2.0: ? → final+
http://hg.mozilla.org/mozilla-central/rev/daeead199d45
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla2.0b7
Attachment #476306 - Flags: approval2.0?
Flags: in-testsuite-
You need to log in before you can comment on or make changes to this bug.