Don't warn people about add-ons compatibility if they are on unsupported version of Firefox

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
8 years ago
a year ago

People

(Reporter: limi, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [target-betaN])

If you have an add-on that doesn't work with 3.6 nor with 4.0, we shouldn't stop you from upgrading your 3.5 to 4.0. If extensions are not compatible with a supported version of Firefox, we shouldn't let them get in the way of upgrading.

We should also consider blocking add-ons that are more than two major versions behind, since they are clearly not maintained anymore.

Comment 1

8 years ago
Your example is not good. Firefox 3.5 is still supported (as far as I've seen, an end-of-life plan for it hasn't been made yet, but I guess it's going to be at least 6 months after Firefox 4.0 is out, so there's an overlap there for the moment), so for the moment it would be Firefox 3.0 to 4.0.

Blocking add-ons from more than two major versions back I would think is a separate fix, so shouldn't it be in a separate bug?
(In reply to comment #1)
> an end-of-life plan for it hasn't been made yet, but I guess it's going to be
> at least 6 months after Firefox 4.0 is out

No, the basic plan is six months after the following release, which was 3.6 released about seven months ago. 3.5 is living on borrowed time. The download page even still says it will be supported until August 2010: http://www.mozilla.com/en-US/firefox/all-older.html

There hasn't been any advertising of impending EOL in the update snippets shown to 3.5 users so maybe given the impending release it will be supported until 4.0 ships. In any case, 4.0 has not yet been released yet no one is offering to update 3.5 users to it. Presumably Limi's scenario is in a future time at which point 3.5 is likely to be no longer supported.

(In reply to comment #0)
> We should also consider blocking add-ons that are more than two major versions
> behind, since they are clearly not maintained anymore.

I object. An unmaintained add-on can work perfectly well and safely on the old version for which is was designed. It still has value to its users despite the developer having moved on.

Disabling it for no reason other than you hope those users will then thank you for turning off their feature and upgrade to a newer Firefox is selfish control-freakery. And wishful thinking. They'll see the blocklisting dialog, they'll see through whatever flimsy reasoning you put on http://www.mozilla.com/blocklist/ , they'll get pissed, and then they're as likely to move to some other browser as upgrade to the latest Firefox.

I believe you can already implement the behavior described in the first paragraph by lying in the extensionVersion attribute in the update snippets to effectively turn off extension compatibility checking. At least that was the fix for the Personas Plus 1.6/Firefox 3.6.10 debacle.
(In reply to comment #2)
> (In reply to comment #0)
> > We should also consider blocking add-ons that are more than two major
> > versions behind, since they are clearly not maintained anymore.
> 
> I object. An unmaintained add-on can work perfectly well and safely on the old
> version for which is was designed. It still has value to its users despite the
> developer having moved on.

I agree, such add-ons should be black-listed only for versions of Fx that they don't support to avoid blocking (or refreining the user to) upgarde.

> I believe you can already implement the behavior described in the first
> paragraph by lying in the extensionVersion attribute in the update snippets to
> effectively turn off extension compatibility checking. At least that was the
> fix for the Personas Plus 1.6/Firefox 3.6.10 debacle.

That's my expected behavior (at least for startup and while browsing : to not interrupt my browsing flow). But as a user I'ld like that Fx warn me too that an addon is compatible only for an unsupported version of Fx (in the Addons manager ?) so I can stop expecting a new release of this addon and uninstall (not only disable) it to clean my addons list and then, if needed, find a substitue addon.
Whiteboard: [target-betaN]

Comment 4

a year ago
You'll almost certainly find related work in or around these areas: 

<https://github.com/mozilla/addons-server/>
<https://github.com/mozilla/addons-frontend/>

Comment 5

a year ago
FWIW a handful of thought-provokers: 

<Unable to install add-on on *BSD · Issue #5647 · mozilla/addons-server
https://github.com/mozilla/addons-server/issues/5647>
– fixed, but Tier-3

Filter by compatibility within collection API · Issue #6279 · mozilla/addons-server
<https://github.com/mozilla/addons-server/issues/6279>

Show incompatible error for missing platform URLs by kumar303 · Pull Request #3419 · mozilla/addons-frontend
<https://github.com/mozilla/addons-frontend/pull/3419>
(In reply to Alex Limi (:limi) — Firefox UX Team from comment #0)
> If you have an add-on that doesn't work with 3.6 nor with 4.0, we shouldn't
> stop you from upgrading your 3.5 to 4.0. If extensions are not compatible
> with a supported version of Firefox, we shouldn't let them get in the way of
> upgrading.
> 
> We should also consider blocking add-ons that are more than two major
> versions behind, since they are clearly not maintained anymore.
As reported, this bug is no longer an issue since app update no longer checks add-on compatibility. Resolving -> wfm.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.