Closed Bug 597658 Opened 11 years ago Closed 11 years ago

ASSERTION: mozHunspellDirProvider not thread-safe: '_mOwningThread.GetThread() == PR_GetCurrentThread()'

Categories

(Core :: Spelling checker, defect)

x86
Linux
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 596476
Tracking Status
blocking2.0 --- final+

People

(Reporter: jdm, Assigned: byronm)

References

Details

Attachments

(1 file)

Attached file Backtrace
This is a new assertion that I've seen start popping up on the Fennec start screen sometime in the last week, I believe.
Looks like some sort of fallout from bug 559942.
Blocks: 559942
Directory service providers are now being enumerated in a non-main thread.  Has this really never come up before?
That's bad. The directory service should be main-thread-only.
Assignee: nobody → byronm
blocking2.0: --- → final+
This will be fixed (unintentionally) by my "Ensure correct cache directory is used for smart_size check" patch for bug 596476.  

> That's bad

How bad?  JST didn't think we should land that bug for beta7 (didn't fix anything serious), but I can land if this changes that equatio (assuming there's still time--when do we freeze?).
Marking dupe of 596476 since that's got the patch with the fix.
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 596476
You need to log in before you can comment on or make changes to this bug.