Last Comment Bug 597689 - Attempt to sort optional toolbar items in order of popularity
: Attempt to sort optional toolbar items in order of popularity
Status: RESOLVED FIXED
[good first bug][mentor=dao][lang=xul]
:
Product: Firefox
Classification: Client Software
Component: Toolbars and Customization (show other bugs)
: Trunk
: All All
: -- enhancement (vote)
: Firefox 13
Assigned To: Ekanan Ketunuti
:
: :Gijs Kruitbosch
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-09-18 07:34 PDT by Dão Gottwald [:dao]
Modified: 2012-02-07 12:18 PST (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (6.01 KB, patch)
2012-02-06 04:56 PST, Ekanan Ketunuti
dao+bmo: review+
Details | Diff | Splinter Review

Description Dão Gottwald [:dao] 2010-09-18 07:34:38 PDT
In a new profile, the customization sheet offers these items:

Print
Activity Indicator
Downloads
History
Bookmarks
New Window
Cut
Copy
Paste
Full Screen
Zoom Controls
Sync

If we had a sense of which items are or will be more popular than others, we could put the more popular ones at the top.
For instance: I'd put Activity Indicator all the way down, as it's a pretty much redundant item. Cut/Copy/Paste seem niche, Sync as well.
Comment 1 Alex Faaborg [:faaborg] (Firefox UX) 2010-09-21 12:18:08 PDT
good idea, only small caveat would be that we should probably keep a few of these grouped together (like cut/copy/paste) even though they might have a spread of usage.
Comment 2 Zhenshuo Fang (:fang) - Firefox UX Team 2012-02-03 13:50:06 PST
It's definitely useful if people want to find their most common used items and put it in the toolbar. But the down side is if we keep changing the position of items then users might get confusing. One possible alternative is order the items based on the popularity among average users and stick to the order.
Comment 3 Dão Gottwald [:dao] 2012-02-06 03:00:39 PST
(In reply to Zhenshuo Fang (:fang) - Firefox UX Team from comment #2)
> One possible alternative
> is order the items based on the popularity among average users and stick to
> the order.

That's the whole idea.
Comment 4 Dão Gottwald [:dao] 2012-02-06 03:22:10 PST
The items are defined here and just need to be reordered:
http://hg.mozilla.org/mozilla-central/annotate/ccbb41b873cd/browser/base/content/browser.xul#l849

Since I don't think we have hard data, I propose that we just move these items down for now:
cut-button
copy-button
paste-button
sync-button
navigator-throbber
tabview-button (remains at the very bottom since it gets added to the toolbar automatically)
Comment 5 Ekanan Ketunuti 2012-02-06 04:56:02 PST
Created attachment 594679 [details] [diff] [review]
patch
Comment 6 Dão Gottwald [:dao] 2012-02-06 05:10:10 PST
Comment on attachment 594679 [details] [diff] [review]
patch

Thanks!
Comment 8 Ed Morley [:emorley] 2012-02-07 12:18:35 PST
Thanks for the patch! :-)

https://hg.mozilla.org/mozilla-central/rev/e5c0df11d314

Note You need to log in before you can comment on or make changes to this bug.