If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

jittery cursor for streaming audio

RESOLVED DUPLICATE of bug 485696

Status

()

Core
Audio/Video
RESOLVED DUPLICATE of bug 485696
7 years ago
7 years ago

People

(Reporter: dherman, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
I just tried http://aminutewithbrendan.com in yesterday's nightly and found that streaming audio is reporting the cursor according to (AFAICT) the ratio

      total played so far
    -----------------------
    total downloaded so far

This isn't a useful ratio for the user to see. Worse, since the total downloaded so far is increasing, the cursor actually moves back and forth as the clip plays. This is distracting and confusing.

Since we don't know the stream length, we can't report

      total played so far
    -----------------------
         stream length

So I suspect we'd be better off doing what 3.6 does, which is just to leave the cursor at the rightmost point.

Dave

Updated

7 years ago
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 485696
You need to log in before you can comment on or make changes to this bug.