crash [@ GetPropertyDescriptorById ]

RESOLVED WORKSFORME

Status

()

Core
JavaScript Engine
--
critical
RESOLVED WORKSFORME
7 years ago
7 years ago

People

(Reporter: Scoobidiver (away), Unassigned)

Tracking

({crash, regression})

Trunk
x86
Windows 7
crash, regression
Points:
---

Firefox Tracking Flags

(blocking2.0 betaN+)

Details

(crash signature)

(Reporter)

Description

7 years ago
Build : Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b7pre) Gecko/20100918 Firefox/4.0b7pre

This is a new crash signature that first appeared in b6pre/20100912 build.
It is #19 top crasher for b7pre/20100917 build.

Signature	GetPropertyDescriptorById
UUID	25fea737-7d2a-400e-a51e-9456c2100918
Time 	2010-09-18 07:32:53.591551
Uptime	180
Last Crash	183 seconds (3.0 minutes) before submission
Install Age	83787 seconds (23.3 hours) since version was first installed.
Product	Firefox
Version	4.0b7pre
Build ID	20100917041014
Branch	2.0
OS	Windows NT
OS Version	5.1.2600 Service Pack 3
CPU	x86
CPU Info	GenuineIntel family 6 model 14 stepping 8
Crash Reason	EXCEPTION_ACCESS_VIOLATION_READ
Crash Address	0x400

Crashing Thread
Frame 	Module 	Signature [Expand] 	Source
0 	xul.dll 	GetPropertyDescriptorById 	js/src/jsapi.cpp:3531
1 	xul.dll 	XPCWrapper::GetPropertyAttrs 	js/src/xpconnect/src/XPCWrapper.cpp:1029
2 	xul.dll 	XPCWrapper::NewResolve 	js/src/xpconnect/src/XPCWrapper.cpp:554
3 	xul.dll 	XPC_SJOW_NewResolve 	js/src/xpconnect/src/XPCSafeJSObjectWrapper.cpp:725
4 	xul.dll 	CallResolveOp 	js/src/jsobj.cpp:4358
5 	xul.dll 	js_LookupPropertyWithFlags 	
6 	xul.dll 	JS_LookupPropertyWithFlagsById 	js/src/jsapi.cpp:3156
7 	xul.dll 	XPCWrapper::Enumerate 	js/src/xpconnect/src/XPCWrapper.cpp:527
8 	xul.dll 	XPCWrapper::CreateIteratorObj 	js/src/xpconnect/src/XPCWrapper.cpp:404
9 	xul.dll 	XPC_SJOW_Iterator 	js/src/xpconnect/src/XPCSafeJSObjectWrapper.cpp:1030
10 	xul.dll 	js_ValueToIterator 	js/src/jsiter.cpp:825
11 	xul.dll 	js::mjit::stubs::Iter 	js/src/methodjit/StubCalls.cpp:2217
12 	xul.dll 	js::Invoke 	js/src/jsinterp.cpp:592
blocking2.0: --- → ?

Updated

7 years ago
blocking2.0: ? → betaN+
I don't see any of these in the past week.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
Crash Signature: [@ GetPropertyDescriptorById ]
You need to log in before you can comment on or make changes to this bug.