Open Bug 597758 Opened 11 years ago Updated 10 years ago

about:support and about:config display accented characters wrongly

Categories

(Toolkit :: Preferences, defect)

defect
Not set
minor

Tracking

()

People

(Reporter: aceman, Unassigned)

Details

(Keywords: polish)

about:support page displays accented characters in preferences names wrongly. I see prefs like this:
print.printer_TlaÃÂiÃÂ¥_do_súboru.print_bgcolor  false
print.printer_TlaÃÂiÃÂ¥_do_súboru.print_bgimages  false

The correct name should be "print.printer_Tlačiť_do_súboru.print_bgcolor" . The page source contains xml UTF-8 declaration and it seems to be parsed as XHTML correctly. Maybe the pref names are doubly encoded or something like that.
Ah, this is on "Mozilla/5.0 (X11; Linux i686; rv:2.0b7pre) Gecko/20100918 Firefox/4.0b7pre".
Maybe we need just a "<meta charset="UTF-8">" in aboutSupport.xhtml ?
Maybe, but the source already contains XML charset declaration. Shouldn't that be enough?
This is the header:
<?xml version="1.0" encoding="UTF-8"?>


<!DOCTYPE html [
  <!ENTITY % htmlDTD PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "DTD/xhtml1-strict.dtd"> %htmlDTD;
  <!ENTITY % globalDTD SYSTEM "chrome://global/locale/global.dtd"> %globalDTD;
  <!ENTITY % brandDTD SYSTEM "chrome://branding/locale/brand.dtd"> %brandDTD;
  <!ENTITY % aboutSupportDTD SYSTEM "chrome://global/locale/aboutSupport.dtd"> %aboutSupportDTD;
]>

<html xmlns="http://www.w3.org/1999/xhtml">
  <head>
    <title>&aboutSupport.pageTitle;</title>

    <link rel="stylesheet" href="chrome://global/skin/aboutSupport.css"
          type="text/css"/>

    <script type="application/javascript;version=1.7"
            src="chrome://global/content/aboutSupport.js"/>
  </head>
The problem exists already in FF 3.6.
Severity: normal → minor
Keywords: polish
This seems to be a general problem in preferences system.
I have now noticed it on Windows too, in about:config. When I create a pref like "print.printer_áš.print_bgcolor = áš". The VALUE is displayed correctly in both pages. But the NAME of the pref is mangled in both pages to "print.printer_áa.print_bgcolor". Other mangling happens with other characters.
The pref in this example is just artificial. However, the ones in comment 0 are real, they were created by my KDE 3 system, it is a default printer name. And the prefs seems to work fine, I can print to that printer (it is "Print to File", so everybody probably has it).
Component: General → Preferences
OS: Linux → All
QA Contact: general → preferences
Hardware: x86 → All
Summary: about:support displays accented characters wrongly → about:support and about:config display accented characters wrongly
Because the preference name gets modified and about:support shows like it is in about:config and the file itself, this seems to be a duplicate of bug 229411. Setting to duplicate, if you disagree, revert.
No longer blocks: about:support++
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 229411
Well, I have no idea what bug 229411 talks about (the description is not that great) and if it is any relevant here. I do not think the filesystem encoding should have anything to do with the file contents (in this case pref names). But we'll see.
If you open about:config and create a preference "foo.tomáš" and set the value "tomáš". Then go into the profile directory and open the prefs.js file. The preference will be written "foo.tomáa" and the value also changes (I see tomáš). So this is no bug in about:support.
I asked the bug filer of bug 229411 and he says it is not the reason for this bug, so I reopen this bug and move it to Toolkit > Preferences
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Status: REOPENED → NEW
Product: Firefox → Toolkit
QA Contact: preferences → preferences
You need to log in before you can comment on or make changes to this bug.