Last Comment Bug 597789 - --disable-rdf breaks the build
: --disable-rdf breaks the build
Status: RESOLVED FIXED
: dev-doc-complete
Product: Core
Classification: Components
Component: Build Config (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla10
Assigned To: Matheus Kerschbaum
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-09-18 21:36 PDT by Mounir Lamouri (:mounir)
Modified: 2011-12-09 08:50 PST (History)
7 users (show)
matjk7: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (23.50 KB, patch)
2011-11-02 15:39 PDT, Matheus Kerschbaum
ted: review+
Details | Diff | Splinter Review
patch for checkin (23.98 KB, patch)
2011-11-07 17:10 PST, Matheus Kerschbaum
matjk7: review+
Details | Diff | Splinter Review

Description Mounir Lamouri (:mounir) 2010-09-18 21:36:59 PDT
On current trunk, we can't build with --disable-rdf
Comment 1 Axel Hecht [:Pike] 2010-09-19 16:33:49 PDT
Moving to build-config, we may as well remove that build option.
Comment 2 Ted Mielczarek [:ted.mielczarek] 2010-09-20 04:20:21 PDT
Can we just remove RDF? :) (But yeah, removing the option sounds fine.)
Comment 3 Justin Dolske [:Dolske] 2010-09-20 15:26:24 PDT
XUL still relies on having localstore.rdf for persisting various things, although I'm starting to kill it off in bug 559505. Makes sense to just remove this --footgun until such time as the platform isn't actually needing it.
Comment 4 Matheus Kerschbaum 2011-11-02 15:39:51 PDT
Created attachment 571483 [details] [diff] [review]
patch
Comment 5 Ted Mielczarek [:ted.mielczarek] 2011-11-07 12:53:36 PST
Comment on attachment 571483 [details] [diff] [review]
patch

Review of attachment 571483 [details] [diff] [review]:
-----------------------------------------------------------------

::: toolkit/library/Makefile.in
@@ +106,1 @@
>  	$(NULL)

Can you change the indent of all three of these blocks while you're here? (To two-space instead of tab.)
Comment 6 Matheus Kerschbaum 2011-11-07 17:10:33 PST
Created attachment 572680 [details] [diff] [review]
patch for checkin
Comment 7 Ed Morley [:emorley] 2011-11-08 00:43:17 PST
https://tbpl.mozilla.org/?tree=Try&rev=1e7c86487f42 :-)
Comment 8 Ed Morley [:emorley] 2011-11-08 03:51:10 PST
https://hg.mozilla.org/integration/mozilla-inbound/rev/1f0be211721f

(Leaving milestone blank for now, since not sure if it will make today's aurora uplift)
Comment 9 Ed Morley [:emorley] 2011-11-08 07:05:56 PST
https://hg.mozilla.org/mozilla-central/rev/1f0be211721f
Comment 10 Eric Shepherd [:sheppy] 2011-12-09 08:50:07 PST
This option was never documented, but its removal is listed on Firefox 10 for developers.

Note You need to log in before you can comment on or make changes to this bug.