Permission error on ftp://ftp.m.o site

RESOLVED WONTFIX

Status

mozilla.org Graveyard
Server Operations
RESOLVED WONTFIX
8 years ago
3 years ago

People

(Reporter: Todd, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2.10) Gecko/20100914 Firefox/3.6.10
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2.10) Gecko/20100914 Firefox/3.6.10

Hi All,

Would one of you guys please fix the permission error on the ftp site that keeps me from downloading:

ftp://ftp.mozilla.org/pub/firefox/releases/latest/win32/en-US/Firefox%20Setup%203.6.10.exe

I do believe the permission should be 755, instead of 644.  (Thunderbird's works fine.)

Many thanks,
-T

ftp> cd /pub/firefox/releases/latest/win32/en-US
250 Directory successfully changed.
ftp> ls -al
227 Entering Passive Mode (63,245,208,138,203,36)
150 Here comes the directory listing.
drwxr-xr-x    2 ftp      ftp          4096 Sep 14 16:18 .
drwxr-xr-x   79 ftp      ftp          4096 Sep 14 16:12 ..
-rw-r--r--    1 ftp      ftp       8534336 Sep 14 16:00 Firefox Setup 3.6.10.exe
-rw-r--r--    1 ftp      ftp           194 Sep 14 16:18 Firefox Setup 3.6.10.exe.asc
226 Directory send OK.

ftp> cd /pub/thunderbird//releases/latest/win32/en-US                                                                
250 Directory successfully changed.
ftp> ls -al
227 Entering Passive Mode (63,245,208,138,218,12)
150 Here comes the directory listing.
drwxr-xr-x    2 ftp      ftp          4096 Sep 15 20:13 .
drwxr-xr-x   50 ftp      ftp          4096 Sep 15 20:13 ..
-rwxr-xr-x    1 ftp      ftp       9419240 Sep 15 20:18 Thunderbird Setup 3.1.4.exe
-rw-r--r--    1 ftp      ftp           323 Sep 15 21:00 Thunderbird Setup 3.1.4.exe.asc
226 Directory send OK.



$ wget "ftp://ftp.mozilla.org/pub/firefox/releases/3.6.10/win32/en-US/Firefox Setup 3.6.10.exe"
--2010-09-18 21:57:38-- ftp://ftp.mozilla.org/pub/firefox/releases/3.6.10/win32/en-US/Firefox%20Setup%203.6.10.exe
           => `Firefox Setup 3.6.10.exe'
Resolving ftp.mozilla.org... 63.245.208.138
Connecting to ftp.mozilla.org|63.245.208.138|:21... connected.
Logging in as anonymous ... Logged in!
==> SYST ... done.    ==> PWD ... done.
==> TYPE I ... done.  ==> CWD /pub/firefox/releases/3.6.10/win32/en-US ... done.
==> SIZE Firefox Setup 3.6.10.exe ... done.
==> PASV ... done.    ==> RETR Firefox Setup 3.6.10.exe ...
No such file `Firefox Setup 3.6.10.exe'.


Reproducible: Always

Updated

8 years ago
Component: General → Release Engineering
Product: Firefox → mozilla.org
QA Contact: general → release
Version: unspecified → other
I think this is IT blocking requests so that the ftp daemon on ftp.m.o doesn't kill the machine. The 'No such file' error from wget is false, probably from it not handling the spaces in the name properly. If you use the commandline ftp client you get a 550 error:
  $ ftp ftp.mozilla.org
  ...
  ftp> cd /pub/firefox/releases/3.6.10/win32/en-US
  250 Directory successfully changed.
  ftp> get "Firefox Setup 3.6.10.exe"
  local: Firefox Setup 3.6.10.exe remote: Firefox Setup 3.6.10.exe
  229 Entering Extended Passive Mode (|||54855|)
  550 Permission denied.
  ftp> 
which is also what you get at requesting 
  ftp://ftp.mozilla.org/pub/firefox/releases/3.6.10/win32/en-US/Firefox%20Setup%203.6.10.exe
using Firefox.

Besides if you want the file you should visit this page in your browser
  http://www.mozilla.com/en-US/firefox/all.html
and get the appropriate link, or use
  http://releases.mozilla.org/pub/mozilla.org/firefox/releases/3.6.10/win32/en-US/Firefox%20Setup%203.6.10.exe

Lets send this over to Server Ops, but I bet it's WONTFIX.
Assignee: nobody → server-ops
Status: UNCONFIRMED → NEW
Component: Release Engineering → Server Operations
Ever confirmed: true
QA Contact: release → mrz
Summary: Permission error on ftp site → Permission error on ftp://ftp.m.o site
(Reporter)

Comment 2

8 years ago
Hi Nick,

I am a consultant and have spread Firefox and Thunderbird around two counties.  That is about 150 users.  I use a 930 line script to download all my updates for the week.  The "latest" link on your ftp site makes scripting a breeze.  I do not have the time to manually go to each site to do a download.  The permissions problem on this particular directory is new as of 3.6.10.  None of the other directories I frequent do this.

"but I bet it's WONTFIX".  I certainly hope they will fix this.  Why in the world would you have a public ftp site that can not be used?

Change the permission from 644 to 755 and I bet this directory starts working again.

-T
Great that you're spreading the word about mozilla apps, but /pub/mozilla.org/firefox/releases/3.6.10/win32/en-US is already 755. Blocking access to those files (over ftp) is done in the config of the ftp daemon. What's wrong with http anyhow ? Have you seen wget's mirror mode ?
WONTFIX.  If you want to download releases, use the releases server.  The ftp server is only intended for nightlies and doesn't have the capacity to handle people direct-linking it on well-advertised releases (this is the whole reason we created the releases server pool).  If you try to download one of these via http from the ftp server you'll get redirected to the releases server.  Unfortunately, ftp has no redirect capability so our only option is to block them.

The block is version-specific, and usually only applies to the latest version.  Quite often, we forgot to move it along to the next version... until someone direct-links a release file via ftp and the server dies.  Then we block it so the server can function again.

Every server in the releases.mozilla.org DNS pool should also support FTP (it's one of the requirements for being part of that pool).  The pathnames are exactly the same, except those servers are missing all of the nightly content and all but the most recent few releases.  So changing "ftp.mozilla.org" to "releases.mozilla.org" in your scripts will probably work just fine.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
Resolution: FIXED → WONTFIX
(Reporter)

Comment 5

8 years ago
(In reply to comment #3)
> Great that you're spreading the word about mozilla apps, but
> /pub/mozilla.org/firefox/releases/3.6.10/win32/en-US is already 755. Blocking
> access to those files (over ftp) is done in the config of the ftp daemon.
> What's wrong with http anyhow ? Have you seen wget's mirror mode ?

No it is not.  You looked at the directory permission instead the files permission:

     -rw-r--r--    1 ftp      ftp       8534336 Sep 14 16:00 Firefox Setup
3.6.10.exe

"-rw-r--r--" is 0644

-T
(Reporter)

Comment 6

8 years ago
(In reply to comment #4)

> Every server in the releases.mozilla.org DNS pool should also support FTP (it's
> one of the requirements for being part of that pool).  The pathnames are
> exactly the same, except those servers are missing all of the nightly content
> and all but the most recent few releases.  So changing "ftp.mozilla.org" to
> "releases.mozilla.org" in your scripts will probably work just fine.

Interesting, firefox gags on ftp://releases.mozilla.com/pub/mozilla.org/firefox/releases/latest/win32/en-US but my ftp client works fine.  This solves the problem.  Thank you!

-T
Product: mozilla.org → mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.