Allowing adding custom Search Engine(s)

RESOLVED DUPLICATE of bug 482229

Status

()

Firefox
Search
--
enhancement
RESOLVED DUPLICATE of bug 482229
8 years ago
8 years ago

People

(Reporter: rtrappman, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.0; rv:2.0b6) Gecko/20100101 Firefox/4.0b6
Build Identifier: Mozilla/5.0 (Windows NT 6.0; rv:2.0b6) Gecko/20100101 Firefox/4.0b6

Currently, users have to go to use addons or other pre-build code to add a search engine to Firefox. I'm suggesting that you allow users to create their own search engines, using a wizard or dialog box, as users may wish to search sites that aren't categorized as "Search Engines" (i.e.: Custom searches, using operators like: SEARCH STRING site:example.com )

Reproducible: Always

Steps to Reproduce:
1. Drop down the search box...
2. Click on "Manage Search Engines".
Actual Results:  
Users are redirected to the Mozilla Addons website.

Expected Results:  
Allow users to choose an addon, or create their own customized search using a dialog box or wizard.
(Reporter)

Updated

8 years ago
Version: unspecified → Trunk
(Reporter)

Updated

8 years ago
Keywords: uiwanted

Comment 1

8 years ago
Think this is a dupe of 482229. Marking as such.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 482229

Updated

8 years ago
Keywords: uiwanted
You need to log in before you can comment on or make changes to this bug.